Issue with Setting 24Hz Refresh Rate on Ubuntu 23.10 with GeForce 1050TI (driver 535.113.01)

Hello everyone,

I’m reaching out to the community after wrestling with an issue that has proven to be quite stubborn. I’m trying to set up a 24.00Hz refresh rate for 4K content on my JVC X7900 projector connected to an Ubuntu machine with a GeForce 1050Ti via HDMI.

Here’s the challenge: my content is exactly 24.00Hz, but my display seems to be locked at 23.98Hz @ 3840x2160. This slight discrepancy is causing dropped frames on my 24.00Hz content, which is quite noticeable and disruptive.

Here’s what I have attempted so far:

  1. I’ve set the NVIDIA config to 4K@24Hz, but the display seems to insist on 23.98Hz as reported by xrandr -q.
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 2210mm x 1250mm
   1920x1080     60.00 +  59.94    50.00    23.98    60.00    50.04  
   4096x2160     24.00    23.98  
   3840x2160     59.94*   50.00    29.97    25.00    23.98  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     60.02  
   1280x800      59.81  
   1280x768      59.99  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
  1. When I try to add a new mode with xrandr --newmode after generating it with gtf or cvt, I receive the following error:
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  35
  Current serial number in output stream:  36
  1. I’ve double-checked the resolution on MacOS and Windows, and it does support 24.00Hz as the resolution I’m aiming for.
  2. The NVIDIA drivers are up to date, and I’ve looked at the proprietary NVIDIA X Server Settings without finding a solution.

Not sure what else to try. Can you guys give me a hint?

Thanks in advance,


The xrandr values come directly from the EDID of the projector, advertises 24Hz only for 4096x2160.
If you want to set up custom resolutions, you’ll need to create an xorg.conf with Option ModeValidation AllowNonEdidModes set.