Failed to set 4K resolution (3840x2160) on GTX 650 Ti

Hi there!

I just bought a Seiki SE39UY04 (39" 4K TV) to use as a monitor and tried to set it up at 4K resolution (3840x2160), but unfortunately, the highest resolution available is 1920x1080… I’m running ubuntu 12.04, on my GTX 650 Ti (4K ready), using nvidia proprietary drivers.

I’m not a newbie regarding Linux (I’m on embedded Linux for years), but I never looked to the video/X subsystem , and I’m somewhat lost (xorg.conf, modelines, xrandr and so are new to me).

I tried to follow the modline recommandations found on an helpfull review on that page, but I’m getting a weird error trying to add a new modeline:

renaud@fractal:~$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 860mm x 480mm
   1920x1080      59.9*+   50.0     24.0     30.0     30.0     25.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x720       59.9     50.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3  
   720x576        50.0     25.0  
   720x480        59.9     30.0  
   640x480        75.0     72.8     59.9  
DVI-D-1 disconnected (normal left inverted right x axis y axis)
renaud@fractal:~$ xrandr --newmode "3840x2160" 307.00 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync
renaud@fractal:~$ xrandr --addmode HDMI-0 "3840x2160"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  153 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  35
  Current serial number in output stream:  36

I tried using nvidia-current (304), nvidia-experimental (310), and even nvidia-319 (319) but no luck.

Here is my dmesg and my lspci. My nvidia bug report is empty.

I even tried to create a 10-monitor.conf into /usr/share/X11/xorg.conf.d, but no changes (at all) :

renaud@fractal:~$ cat /usr/share/X11/xorg.conf.d/10-monitor.conf
Section "Monitor"
  Identifier "Monitor0"
  Modeline "3840x2160" 307.00 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync
EndSection
Section "Screen"
  Identifier "Screen0"
  Device "HDMI-0"
  Monitor "Monitor0"
  DefaultDepth 24
  SubSection "Display"
    Depth 24
    Modes "3840x2160" "1920x1080"
  EndSubSection
EndSection

I’m stuck, and this is very frustrating

Any hints appreciated ?

I’m having trouble getting the SE39UY04 to work in 3840x2160 mode using Fedora Linux 19.
1920x1080 mode works fine.

Does anyone out there have a recipe to follow to get this to work?

Thanks.

I’m trying too, but with 1440x900, and nothing about work
https://devtalk.nvidia.com/default/topic/596183/linux/nvidia-driver-with-gtx-650-and-arch-linux-refusing-more-than-1024x768/

Internally filed Bug 1361058 :Failed to set 4K resolution (3840x2160) hdmi on GTX 650 Ti to track this issue.

nono240, Can we get an nvidia-bug-report.log file with verbose mode validation enabled? (nvidia-xconfig --mode-debug)

The gtx 650 ti works with the seiki display. I know as I was using it to drive my 39 inch seiki @ 4k on my machine at work which now has a gtx 670.

First you must be using 319.23 or newer.

Second you need this under the device section:

Option “ModeValidation” “AllowNon60hzmodesDFPModes, NoEDIDDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoDFPNativeResolutionCheck, NoMaxSizeCheck, NoMaxPClkCheck, AllowNonEdidModes, NoEdidMaxPClkCheck”

One (of the many) problems is that even on 319.23 it still reports the HDMI-0 as 165 Mhz max pixelclock so without some of the modevalidation overrides it won’t work.

Your problem is:

[ 12.618] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-0 is invalid: the
[ 12.618] (WW) NVIDIA(GPU-0): checksum for EDID version 1 is invalid.

Unfortunately nvidia linux drivers verify the checksum of the EDID and it will not use them if its invalid and some displays do not have valid checksums on their EDID like the Yamakasi Catleap (the windows drivers do not do this).

You can use the same mode validation line I added although from the resolution I am guessing its an LCD from the resolution but hooked up via VGA? I would switch over to DVI of HDMI if it has that option. If an LCD over HDMI/DVI I would give this modeline a shot:

Modeline “1440x900” 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

If its really a CRT/VGA I would do:

Modeline “1440x900” 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

Under the monitor section. You may also want to up the horiz/vertical refresh values under the monitor section as well.

Fixed thanks to houkouonchi:

http://ubuntuforums.org/showthread.php?t=2164924

But, it required lastest drivers from swat-team :-/

It was a BIG hassle, thumbs up to houkouonchi!

If you’re sure the EDID really is valid despite its invalid checksum, you can also just overrid the checksum check:

Option "<a target='_blank' rel='noopener noreferrer' href='"http://people.freedesktop.org/~aplattner/nvidia-readme/xconfigoptions.html#IgnoreEDIDChecksum"'>IgnoreEDIDChecksum</a>" "CRT-0"