4k over HDMI not working with Sony screens?

In the release notes of 319.23 (http://www.nvidia.co.uk/object/linux-display-amd64-319.23-driver-uk.html) it says:

“Added support for HDMI 4K resolutions. Using a 4K resolution with an HDMI display requires a Kepler or later GPU.”

We tested an ASUS Titan 6GD5 with 319.32 (and 325.08) on Linux 64-bit (Ubuntu 12.10, X.org 1.13.0) with a Sony Bravia X9005 55" screen and its bigger 65" brother. This was using an HDMI cable, we made sure it was a high-speed cable. In no way could we get the Titan to detect a resolution higher than 1920x1080.

This was in an electronics store, so we couldn’t do endless tests, but there was a local Windows demo machine with a Radeon 7700 that managed to do 3840x2160 on the 55" screen without problems. We didn’t test with our system under Windows as it was Linux only (and our preferred OS). We also didn’t test yet with forcing e.g. 3840x2160@24.

Did something change in the driver since 319.23 that disables 4k over HDMI? What screen was used to certify the 4k-over-hdmi capability in the first place? Any other tricks we might try?

If it’s like on the Seiki 4K, the TV reports a correct EDID but the GPU doesn’t report correctly its max HDMI bandwidth to the driver (165MHz vs 330MHz) so the modeline cannot be validated.

These options the ‘Device’ section should tell the driver ‘never mind, it’ll work out’:

Option         "ModeValidation" "DFP-1: NoDFPNativeResolutionCheck, NoMaxPClkCheck, NoVertRefreshCheck"
Option         "ExactModeTimingsDVI" "True"

Then ‘nvidia-auto-select’ should work right away in ‘Screen’ section.

I hope this help.

Luc

It seems to be the EDID info that’s the problem, actually. We dumped it to file from nvidia-settings (for each of the HDMI ports), but the max. resolution is 1920x1080 in all of them, as reported by edid-decode. I assume the EDID data saved by nvidia-settings is the raw data as reported by the screen, before any filtering based on modeline and such has been performed?

If the 4k modes aren’t in EDID at all (that would be kind of weird) you could try these seiki modelines:

3840x2160@30Hz

Modeline “3840x2160_30” 296.70 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync

3840x2160@25Hz

Modeline “3840x2160_25” 297.00 3840 4896 4984 5280 2160 2168 2178 2250 +hsync +vsync

3840x2160@24Hz

Modeline “3840x2160_24” 296.75 3840 5116 5204 5500 2160 2168 2178 2250 +hsync +vsync