4K resolution don't appear in Modeline for Xorg server

I have an Intel Xeon with Quadro M4000. OS : Debian Bookworm (12).
2 screen connected on this card: A standard Monitor (1600px) and a Sony TV 4K .

This configuration worked well with driver “nouveau”, TV display a 4K picture 3840x2160@24.
I need to encode video in Realtime. I failed to use hardware accel with “nouveau”. So I installed nvidia driver.

With Nvidia Driver, TV displays 1920x1080 pictures, not more.

I activated ModeDebug in xorg.conf, and I think problem come from this section (extract from Xorg.log) :

[ 79305.276] (II) NVIDIA(GPU-0): --- Building ModePool for SONY TV  *02 (DFP-1) ---
...
[ 79305.277] (WW) NVIDIA(GPU-0):   Validating Mode "3840x2160_24":
[ 79305.277] (WW) NVIDIA(GPU-0):     Mode Source: EDID
[ 79305.277] (WW) NVIDIA(GPU-0):     3840 x 2160 @ 24 Hz
[ 79305.277] (WW) NVIDIA(GPU-0):       Pixel Clock      : 296.70 MHz
[ 79305.277] (WW) NVIDIA(GPU-0):       HRes, HSyncStart : 3840, 5116
[ 79305.277] (WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 5204, 5500
[ 79305.277] (WW) NVIDIA(GPU-0):       VRes, VSyncStart : 2160, 2168
[ 79305.277] (WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 2178, 2250
[ 79305.277] (WW) NVIDIA(GPU-0):       Sync Polarity    : +H +V
[ 79305.277] (WW) NVIDIA(GPU-0):     Mode is rejected: PixelClock (**296.7** MHz) too high for
[ 79305.277] (WW) NVIDIA(GPU-0):     Display Device (**Max: 165.0 MHz**).
[ 79305.277] (WW) NVIDIA(GPU-0):     GPU extended capability check failed.
[ 79305.277] (WW) NVIDIA(GPU-0):     Mode "3840x2160_24" is invalid.

Because all working well with “nouveau”, I think this is a problem with Nvidia configuration.

Thank you for help.
nvidia-bug-report.log.gz (622.2 KB)

DFP-1 in your configuration is a single-link TMDS connection with a maximum pixel clock of 165 MHz. If your monitor requires a higher pixel clock, you can try setting

Option “ModeDebug” “NoMaxPClkCheck”

in /etc/X11/xorg.conf.

Thank you for the answer.
I tested your option. It doesn’t work.
Joined, my Xorg config and the log.
maybe :

[934735.058] (WW) NVIDIA(GPU-0):   Validating Mode "3840x2160_24":
[934735.058] (WW) NVIDIA(GPU-0):     Mode Source: EDID
[934735.058] (WW) NVIDIA(GPU-0):     3840 x 2160 @ 24 Hz
[934735.058] (WW) NVIDIA(GPU-0):       Pixel Clock      : 296.70 MHz
[934735.058] (WW) NVIDIA(GPU-0):       HRes, HSyncStart : 3840, 5116
[934735.058] (WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 5204, 5500
[934735.058] (WW) NVIDIA(GPU-0):       VRes, VSyncStart : 2160, 2168
[934735.058] (WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 2178, 2250
[934735.058] (WW) NVIDIA(GPU-0):       Sync Polarity    : +H +V
[934735.058] (WW) NVIDIA(GPU-0):     The EDID for SONY TV  *02 (DP-1) contradicts itself: mode
[934735.058] (WW) NVIDIA(GPU-0):     "3840x2160" is specified in the EDID; however, the EDID's
[934735.058] (WW) NVIDIA(GPU-0):     valid VertRefresh range (48.000-62.000 Hz) would exclude
[934735.058] (WW) NVIDIA(GPU-0):     this mode's VertRefresh (23.976 Hz); ignoring VertRefresh
[934735.058] (WW) NVIDIA(GPU-0):     check for mode "3840x2160".
[934735.058] (WW) NVIDIA(GPU-0):     Unable to determine HDMI 2.1 Fixed Rate Link
[934735.058] (WW) NVIDIA(GPU-0):     configuration.
[934735.058] (WW) NVIDIA(GPU-0):     Mode is rejected: Unable to construct hardware-specific
[934735.058] (WW) NVIDIA(GPU-0):     mode timings.
[934735.058] (WW) NVIDIA(GPU-0):     GPU extended capability check failed.
[934735.058] (WW) NVIDIA(GPU-0):     Mode "3840x2160_24" is invalid.

DFP-1 in your configuration is a single-link TMDS connection with a maximum pixel clock of 165 MHz

Ok, how can I change this ?

xorg.conf.txt (2.3 KB)

Xorg.1.log (322.0 KB)

Option “ModeValidation” “NoMaxPClkCheck,NoVertRefreshCheck” doesn’t help.
Why this installation work with nouveau driver not with Nvidia drivers ?

I’ve now seen this multiple times, especially on Quadros, that using passive DP2HDMI adapter cables only results in a hdmi 1.0 @165Hz TMDS and not the expected hdmi 1.3 @300MHz TMDS.
@julien.lamome a workaround would be using an active DP2HDMI2.0 converter with support for 4k@60Hz

Thank you generix for the tip.
I use an DP to HDMI adapter. I will search active converter (24Hz, is suffisent).
The mystery: why nouveau driver is ok ?

I found an other adapter in my pocket. Now I can select all modes supported by TV.

IDK, different threshold for connection, driver bug?