Setting default refresh rate

I recently picked up a 1440p monitor with 60Hz, 120Hz and 144Hz refresh rates. When the computer starts it defaults to 60Hz (well, 59.95) and I must manually change it to 144. The default setting in the nvidia-settings is “Auto” and “Auto” for resolution and refresh rate.

I’m using Mint 18.1 and have a GTX 970 and GTX 460 in my system.

I’ve selected 2560x1440, 144Hz and saved it to my X configuration file but after reboot it still goes back to 2560x1440, 59.95Hz. My xorg.conf is:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "2560x1440_144 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Is there a way to make this stick after reboot?

Thanks!

Will your monitor’s refresh rate stay at 120Hz after a reboot? I’ve seen reports on the Windows side of this forum which claim that settling for 120Hz is more reliable than 144Hz.

As well, can a GTX 970 even drive a 2560x1440 display at that high of a frame / refresh rate?

If I’m booting to windows the selected refresh rate will remain regardless of it being 120Hz or 144Hz. In Linux it just defaults to 60Hz no matter what the refresh rate was at the time of reboot.

As to the GTX 970 drive 2560x1440 it really depends on the game. I’ve been playing through the Borderlands Pre-Sequel and most of the time I’m above 144Hz (with high quality settings). Even when it’s below 144Hz the tearing is not noticeable based on the high refresh rate. With modern games that really push the visual quality then frame rates are lower but even then, tearing can rarely be seen (even if it’s occurring).

Even in general desktop use everything is much smoother at 144Hz as opposed to 60Hz.

Probably my biggest performance hit comes from using the GTX 460 as a Physx card. All the added visuals and particles can really make things crawl in a big firefight.

I suppose that you’ve tried the ‘Save Current Configuration’ option via the ‘nvidia-settings Configuration’?

I’m out of my depth on this since I only have a single 60Hz monitor thus no way of testing different options.

It’s interesting to learn that a GTX 970 can perform that well at 2560x1440. Exactly which '970 and monitor model do you have?

Correct… See the xorg.conf above. That is what was generated when I tried the “Save Current Configuration”.

I’ll take a look at which 970 I have when I get home. I played the Korean Panel Lottery and got a Pixio PX277 (https://www.buypixio.com/products/px277). Some people had issues on early production run monitors but mine has been flawless. No dead pixels and very little IPS glow (unnoticeable in anything but a totally black screen). I ended up getting mine on sale at Newegg for $349 and it was worth every penny.

A long shot:

November 30th, 2006
Howto: Load your nVidia settings on startup
https://ubuntuforums.org/showthread.php?t=310016

How to make an nvidia-settings Configuration file load at boot time
https://duckduckgo.com/?q=How+to+make+an+nvidia-settings+Configuration+file+load+at+boot+time&t=hs&ia=qa

Edit: man nvidia-settings

'Good score on the Pixio PX277.

Check your X server log for lines that have “Setting mode” in them. Typically when mode settings from xorg.conf don’t seem to be sticking, it’s because your desktop environment changes the mode again as soon as it starts. I’m not too familiar with Mint but you might try changing the refresh rate through its display configuration control panel rather than through nvidia-settings.

Yeah it really depends on your DE. They have their own display settings, which usually overrides any xorg.conf setting.

I.E. if your mint is with cinnamon DE, you can first do the settings you want with nvidia-settings. After that you should open DEs own display settings prog(menu->display). Click detect displays, apply and finally save configuration. Of course you don’t even have to use nvidia-settings for it at all, you should be able to use that DEs own display setting for it.

If my memory servers me right, gtk flavored DEs stores their display configuration to file ~/.config/monitors.xml(I have kde myself, so I can’t be sure about it).

This was it! In Mint Cinnamon there is an option to set resolution in the System Settings control panel but no option for refresh rate. By setting it in the nvidia-settings then going to the System Settings and hitting “Apply” the 144 Hz survived the reboot.

Thanks everyone for the help!