GPU in microk8s is not appearing as an add-on

Hello,

i have a couple of AGX Xavier devices, which i try to connect to a microk8s cluster in order to create containerized services. For both i have used the sdkmanager to install all packages, etc. It seems to have worked fine (i have also installed the NVIDIA runtime).

As a bare metal device i managed to run a human presence detection model based on yolo following (Installing PyTorch and YOLOv5 on an NVIDIA Jetson Xavier NX).

After installing microk8s following a typical snap install i can deploy a micro service (e.g., nginx), based on containerd runtime (from snap info microk8s version 1.22.3, and kubect v1.22.3-3+64e63223b19811).

Btw, i had do disable ha-cluster, since it uses calico for the cni, and calico kernel modules are not installed in the legacy tegra kernel (it misses some kernel modules such as ip_set). To solve this i disabled ha-cluster add on, which switches to flannel networking and works fine, (i.e., internet access from the pod)

The problem is that the microk8s GPU add-on (https://microk8s.io/docs/addon-gpu) is missing from the microk8s status command. In a legacy x86 system i see the add-on present, however not the the agx xavier.

Is there an extra step for this with respect to the installation of the GPU? Did i miss something?

Also, i am using containerd as my runtime and NOT docker, is this a problem?
I have also seen this Announcing containerd Support for the NVIDIA GPU Operator | NVIDIA Developer Blog

Any help appreciated.

all the best,
Pavlos.

Wrong forum. Please check to post in the compute related forum. Here we deal with virtual GPU related topics