Gstreamer read USB camera and send rtmp

when I run the following Gstreamer pipeline on Xavier , I came with the error with rtmp

nvidia@nvidia:~/Videos$ gst-launch-1.0 v4l2src ! ‘video/x-raw, width=(int)640, height=(int)480’ ! nvvidconv ! omxh264enc bitrate=300000 control-rate=variable ! h264parse ! queue ! flvmux name=muxer alsasrc device=hw:1 ! audioresample ! “audio/x-raw,rate=48000” ! queue ! voaacenc bitrate=32000 ! aacparse ! queue ! muxer. muxer. ! rtmpsink location="rtmp://192.168.1.114/home/nvidia/Videos/test live=1 "
Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstAudioSrcClock
Redistribute latency…
Framerate set to : 30 at NvxVideoEncoderSetParameterNvMMLiteOpen : Block : BlockType = 4
===== NVMEDIA: NVENC =====
NvMMLiteBlockCreate : Block : BlockType = 4
H264: Profile = 66, Level = 40
ERROR: from element /GstPipeline:pipeline0/GstRTMPSink:rtmpsink0: Could not open resource for writing.
Additional debug info:
gstrtmpsink.c(245): gst_rtmp_sink_render (): /GstPipeline:pipeline0/GstRTMPSink:rtmpsink0:
Could not connect to RTMP stream "rtmp://192.168.1.114/home/nvidia/Videos/test live=1 " for writing
Execution ended after 0:00:01.829953125
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …


I google this question and to install Nginx on Xavier, but when I start the nginx service , I came with the following question:

nvidia@nvidia:~ sudo service nginx start Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details. nvidia@nvidia:~ systemctl status nginx.service
● nginx.service
Loaded: loaded (/etc/init.d/nginx; generated)
Active: failed (Result: exit-code) since Thu 2020-02-13 15:24:16 CST; 10s ago
Docs: man:systemd-sysv-generator(8)
Process: 8467 ExecStart=/etc/init.d/nginx start (code=exited, status=203/EXEC)

2月 13 15:24:16 nvidia systemd[1]: Starting nginx.service…
2月 13 15:24:16 nvidia systemd[8467]: nginx.service: Failed to execute command:
2月 13 15:24:16 nvidia systemd[8467]: nginx.service: Failed at step EXEC spawnin
2月 13 15:24:16 nvidia systemd[1]: nginx.service: Control process exited, code=e
2月 13 15:24:16 nvidia systemd[1]: nginx.service: Failed with result ‘exit-code’
2月 13 15:24:16 nvidia systemd[1]: Failed to start nginx.service.

Could anybody show me the key point to solve this question ,I will be appreciated for your help!

Hi,
Please check
https://devtalk.nvidia.com/default/topic/1069565/jetson-nano/gstreamer-uses-usb-camera-to-implement-rtmp-push-stream/post/5418367/#5418367

In general it should be combination of ‘flvmux ! rtmpsink’. Your pipeline looks OK and not sure why it does not work. You may run with software encoder x264enc and raise it in gstreamer forum:
http://gstreamer-devel.966125.n4.nabble.com/
Users on the forum have more experience in constructing pipelines. You may see if they can help you work out a solution. Once the pipeline works, it shall work just fine by replacing x264enc with nvvidconv ! nvv4l2h264enc.

I solved this problem by installing Nginx and run ./nginx