Gstreamer video sink problem


We have a gstreamer pipeline running on Jetson TK1. Here is the pipeline:

gst-launch rtspsrc location=rtsp:// latency=500 ! gstrtpjitterbuffer ! rtph264depay ! nv_omx_h264dec ! ‘video/x-raw-yuv’ ! plugin master-ip=${CAMIP} ! nvvidconv ! ‘video/x-nv-yuv’ ! nv_omx_hdmi_videosink

We have created a custom plugin as you can see, and the output is shown on the screen with “nv_omx_hdmi_videosink” element.

We have tried to use the same pipeline on Jetson TX1; the only difference during compile is to change cuda-6.5 from cuda-7.0. When trying to execute the same pipeline, I got the following error:

WARNING: from element /GstPipeline:pipeline0/GstOmxHdmiVideoSink:omxhdmivideosink0: A lot of buffers are being dropped.
Additional debug info:
gstbasesink.c(2875): gst_base_sink_is_too_late (): /GstPipeline:pipeline0/GstOmxHdmiVideoSink:omxhdmivideosink0:
There may be a timestamping problem, or this computer is too slow.
NvxBaseWorkerFunction[2497] comp OMX.Nvidia.render.hdmi.overlay.yuv420 Error -2147479552 
ERROR: from element /GstPipeline:pipeline0/GstOmxHdmiVideoSink:omxhdmivideosink0: GStreamer encountered a general resource error.
Additional debug info:
/dvs/git/dirty/git-master_linux/external/gstreamer/gst-openmax/omx/gstomx_util.c(1164): omx_report_error (): /GstPipeline:pipeline0/GstOmxHdmiVideoSink:omxhdmivideosink0:
There were insufficient resources to perform the requested operation
Execution ended after 7510328160 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

In multimedia user guide, I saw that “nv_omx_hdmi_videosink” is deprecated, so I have tried to use “nv_omx_videosink” instead. This time, I can see the video on the screen, but it is like frozen, not moving. I can get only 1 frame at every 20 seconds.

I have also applied the maximum performance script. What can be wrong? This pipeline is working 25 fps on Jetson TK1 without any problem, but I am not able to run it on Jetson TX1.


No idea?

Hello, fikret:
In TX1, you can try ‘nvhdmioverlaysink’.