Gsync compatible VRR - Low Framerate Compensation (LFC) transition not seamless, unlike on Windows

My Lenovo G27q-20, which is a Gsync compatible certified device, has a VRR range of 48-165Hz. When frame rate drops below 48fps, there is a noticeable stutter event happening. I can reproduce this in Strange Brigade native Vulkan (Proton) by increasing render resolution scale to 200%, so I can drop below 48fps in some scenes with my RTX 3060.

On Windows, this transition is seamless, i.e. there is no noticeable stutter event. MangoHUD frame time graph shows flat line for frame render times, so the stutter apparently happens at VRR presentation stage. Maybe it’s related to frame doubling, that is required to make LFC transition seamless (see old pcper Gsync/VRR reviews). It doesn’t matter if vsync is enabled or not. KWin compositor of the Xorg session is manually suspended so it’s guaranteed not to interfere.

Has been happening for many months and drivers, maybe it never worked right. Just confirmed the issue again with driver 515.43.04 on Arch Linux 5.18.

Can you please try once with Latest Production Branch Version 515.48.07.
If issue still persists, please share nvidia bug report and repro video for reference.

515.48.07 still shows the issue.

How I can reproduce the issue in Strange Brigade:

Note that the issue itself can’t be captured on a video, and also capturing the screen with an external camera probably wouldn’t really work. It’s not a very hard stuttering, but is very annoying regardless, as it happens repeatedly when fps are close to the lower VRR range limit. log file:
nvidia-bug-report.tar.gz (792.9 KB)

Btw: I’ve noticed that VRR with the open source Nvidia kernel driver is not just missing for Wayland, but also Xorg. It doesn’t show up in nvidia-settings and isn’t used.