GTX 1050TI VDPAU deinterlacers.

VDPAU advanced x1 & x2 de-interlacing do not appear to function properly with driver 375.26 on GTX1050ti.
BOB & temporal DI look as expected (okay).
Playback shows interlaced combing artefacts with mpv & MythTV.
VDPAU trace/debug logs show no errors & look to show expected function calls.

Recordings are typical broadcast H264 1080i50.
Have tried i60 video files & other refresh rates with no success.
Scaling in GPU from 1080 to 2160 (4K) or just 1080 output makes no difference.

Same driver (375.26) on GTX650 playing the same recordings with 2x Adv. DI VDPAU looks okay/good.
Driver 340.xx on GT240 playing the same recordings with 2x Adv. DI VDPAU looks okay/good.

IMO appears that the GTX1050ti firmware/hardware is the problem.

Thanks.

GTX 1050TI VDPAU with Driver 378.09 still does not work right (advanced x1 or x2 DI).

Is VDPAU not going to be continued / supported on the newer video cards?

Hi Bipedal, Is this issue reproduce with MPlayer too ? Could you please share reproduction steps in detail, that will help us to replicate this issue here to investigate? Please provide video recording of issue to understand it. Also provide nvidia bug report as soon as issue hit. Any command or options you used while reintroducing this issue? Is any older driver working as expected ?

Hi Sandip,
Not tried with ‘raw’ mplayer, but problem is same (visually) with mpv & MythTV.

Nothing special about my video files, just broadcast H264 in mpeg-ts container.
These test tracks show the problem:
http://www.avsforum.com/forum/26-home-theater-computers/1157287-hd-1080i-test-pattern-determine-vector-adaptive-deinterlacing-others-icl-ticker.html

Play any interlaced video file with x1 or x2 advanced de-interlacing & eyeball the display… with any motion in video there is a big x-axis offset between consecutive frames.
It looks like frames being played in the incorrect order.

I enabled VDPAU library debug/trace & switched between the different de-interlacers (mythtv)…
No errors & all looks as I expected…

I just use temporalx2 DI now.

There is no old driver for GTX 1050ti.
All the old drivers worked fine with old GT240 (for many years) on same video.
And the old card is not supported by new driver.

Thanks.

Hi Bipedal,
Could you please share reproduction steps in detail, that will help us to replicate this issue here to investigate?

Please provide video recording of issue to understand it.

Also provide nvidia bug report as soon as issue hit.

Any command or options you used while reintroducing this issue?

>>Nothing special about my video files, just broadcast H264 in mpeg-ts container.

How I can do that? do I need to use any other application?

>>These test tracks show the problem: http://www.avsforum.com/forum/26-home-theater-computers/1157287-hd-1080i-test-pattern-determine-vector-adaptive-deinterlacing-others-icl-ticker.html

Please suggest which file should I download and test/play with?

>>Play any interlaced video file with x1 or x2 advanced de-interlacing & eyeball the display…

How I can apply x1 or x2 advanced de-interlacing and eyeball the display in mpv & MythTV?

>>with any motion in video there is a big x-axis offset between consecutive frames.
It looks like frames being played in the incorrect order.

How to check that? do you have nay photo or video recording?

>>switched between the different de-interlacers (mythtv) in mpv & MythTV.
How amd what? What is your observation ?

Hi Sandip,

Any of the interlaced test tracks from AVS forum (as linked to previously) show the problem.
Every interlaced video file I have tried (samples from all over the world) shows the problem.

I suggest the video file “Slices_MPEG2_NTSC_1080i-29.97.zip” or H264 NTSC one:

There is no error/bug as such… Advanced x2 DI does not work correctly on GTX 1050ti with any of the potential drivers to date.

I have some photos but can not connect/login to your ftp server.

MythTV allows you to specify the de-interlacer in frontend playback options & also allows you to dynamically change the de-interlacer via the OSD GUI (very temporary setting).

Advanced x2 DI (temporal & spatial):

mplayer -vc ffh264vdpau -vo vdpau:deint=4 Slices_H.264_NTSC_1080i-29.97.ts

Temporal x2 DI:

mplayer -vc ffh264vdpau -vo vdpau:deint=3 Slices_H.264_NTSC_1080i-29.97.ts

Forget about mpv, it seems to only allow yadif deinterlacing which implies copy back or CPU decoding.
None of the ‘-vo-vdpau-deint=n’ options seem to work.

Note:
Advanced DIx2 works fine with GTX 650 & driver version 378.13.

Thanks.

DSCF3189-ADVANCEDx2.JPG
DSCF3188-TEMPORALx2.JPG

DSCF3189-ADVANCEDx2.JPG

>>I have some photos but can not connect/login to your ftp server.
You can attach to your above post

>>There is no error/bug as such… Advanced x2 DI does not work correctly on GTX 1050ti with any of the potential drivers to date.

Looks then this issue is specific to only GTX 1050ti. Did you see this issue on any similar gpu?

Sandip,

AIUI the GTX 1050 ti has similar video engine to other ‘1000’ series but made at different wafer fab/foundry with a new feature size.
It is not inconceivable that the hardware design has evolved.

I don’t have any other ‘1000’ series video cards.
Real shame if this h/w is borked as GTX 1050 & ti where looking like the best HTPC video card on the market.

As I understand… de-interlacing, inverse telecine & HQ scaling are post processing performed (mix & render) in shader hardware (shader programs in driver firmware) & not fixed hardware functions in the video d/encoder ASIC.
If that is true then there is the slim possibility it could be fixed.

Thanks,
B.

Hello,

I can also confirm the problem with the advanced deinterlacer using a GP107 GPU.

Here I uploaded a nvidia-bug-report, the *.ts file I was using, a mplayer.log and two screenshots - one with a GK208 GT 710 that shows a proper looking image and the other one with my GP107 GTX 1050 Ti:

https://mega.nz/#!bdIgWDrB!RGuUIJfWFLdORMSt53Tgv2phGO43wPbEhRumAknxskU

Look at the screenshots and look at the news-banner at the bottom and you will see the difference.
I know from two other users with a GTX 1050 who have the same problem.

I hope this helps to investigate this issue.

Best Regards,
Bart

BTW: I wasn’t able to upload to your ftp. It was telling me that a password is required.

Bipedal, Could you please provide nvidia bug report of your system?

Hi tecfreak, It would be good if you also provide command you used to reproduce this issue? OR its same as of Bipedal? What desktop env you are running Unity, gnome, kde or else?

>>I know from two other users with a GTX 1050 who have the same problem.
From where you got this reference ?

Almost the same.

mplayer -vc ffh264vdpau -vo vdpau:deint=4 -fs 00002.ts

KDE with “Suspend compositor for full screen windows” under the Display>Compositor settings.

It is a german forum where two other users encountered the same issue with a GTX 1050 and vdr-plugin-softhddevice which uses VDPAU as output/decoding and for post-processing.
http://www.vdr-portal.de/board18-vdr-hardware/board84-allgemein/130318-problem-beim-deinterlacing-mit-gigabyte-geforce-gtx-1050-d5-2g/?highlight=

I attached my zip file to this post. Didn’t knew that this is possible. Sorry, my bad.

Were you able to reproduce this issue?

If you use my test file (00002.ts) you can see at the GK208.png screenshot how it has to look like if deinterlacing is working properly and at the GP107.png how it looks like when using the Pascal GPU.
deinterlacer_bug-report.zip (16.2 MB)

Hi,

I suffer from the same problem with a GTX 960. The problem can be reproduced using tecfreak’s file and command. IIRC, it used to work several months ago it seems to be a regression.

Regards
N0T3P4D

So at least the GM206 or the Maxwell 2.0 gen is affected too.

@N0T3P4D
Could you maybe figure out which driver was the last properly working one to figure out which release introduced this regression?

Bipedal reported the 375.26 already as not properly functioning and I could go down to 375.20 which was the first release that supports my GTX 1050 Ti.

Actually, I did this a few months ago but forgot to complain here.
If I read the package manager logs correctly, 361.45.18 was good and 364.12 was not.

Unfortunately, I cannot check this right now. The GPU is passed through to a VM and the older drivers don’t work under kernel 3.16, which is ancient enough for the drivers:

Feb 25 13:34:22 [kernel] NVRM: RmInitAdapter failed! (0x2c:0x59:1159)
Feb 25 13:34:22 [kernel] NVRM: rm_init_adapter failed for device bearing minor number 0

As I think that this is related to the virtualization, I could try bisecting it on bare metal next weekend if absolutely necessary.

Hi N0T3P4D, I think issue reported here is specific to GTX1050ti GPU. Are you sure you also facing exact same issue? Are you also using same commands used by other users in this thread? Please confirm your issue reproduction steps, commands and nvidia bug report. Did you hit this issue on baremetal or VM?

We are tracking this issue under : 200283359

Hi sandipt,

at least the symptoms are exactly the same:

mplayer -vc ffh264vdpau -vo vdpau:deint=4 -fs 00002.ts produces artefacts,

mplayer -vc ffh264vdpau -vo vdpau:deint=3 -fs 00002.ts does not and is properly deinterlaced. The sample is the same as tecfreak’s. The problem also occurs with VC1-encoded video files.

When the problem started (around June), I hit this issue on bare metal and standard (non-hardened) Gentoo. I was able to solve it by downgrading the driver to an older version.

If you want me to reproduce and confirm it on bare metal, please tell me your favorite distribution, kernel version and window manager.

Best regards
N0T3P4D
nvidia-bug-report.log.gz (209 KB)

I hope this issue will be solved in the next release.

Thank you very much so far sandipt.

Hello,

any progress with this issue?
I have also found out, that VDPAU HQ Scaling isn’t working either.

It seems, that the whole VDPAU Video Mixer stuff is affected.