GTX 1080, newest drivers, Cuda Toolkit 8.0.27 RC installed. Nothing working.

I used to use several CUDA accelerated programs on my rig. Specifically FurryBall GPU Renderer, Octane, and Skanect 3D Scanner.

All of these, since upgrading to 2x GTX 1080s are reporting that CUDA is not supported by my card, or just don’t work.

I’m trying to find out if I just have to wait for software updates from the companies to support the card, or is there something else going on?

It’s likely that you just have to wait for software updates.

If you installed the cuda toolkit, you can follow the installation guide to verify that it is installed correctly.

I’ve tried installing Cuda 8 to work with my GTX 1080 on both Ubuntu 16.04 and Mint 17.4 (Ubuntu 14.04) with no success.

I think what’s happening is that the 1080 requires driver 367.18, but installing this driver crashes X11.

Tried multiple times with fresh installs of linux, cuda, and drivers.

txbob is probably right-- just wait for the software to catch up.

Anyone else with this experience? Any ideas or suggestions?

@StewJo, you can try to do tty or ssh if your X server isn’t giving you a gui.

Once I installed everything, I ran nvidia-smi which reports the following:

Wed Jun  8 16:27:11 2016       
| NVIDIA-SMI 367.18     Driver Version: 367.18         |                       
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  Graphics Device     Off  | 0000:01:00.0      On |                  N/A |
| 41%   61C    P0    56W / 180W |    983MiB /  8105MiB |     33%      Default |
|   1  Graphics Device     Off  | 0000:02:00.0     Off |                  N/A |
| 37%   56C    P0    47W / 180W |    994MiB /  8113MiB |     22%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|  No running processes found                                                 |

Notice that there are “No running processes found”, even though I am running programs.
Also, the name comes back as “Graphics Device”.

One problem that I ran into is that the cuda 8 installation wants to use an old driver version (362?) that doesn’t support the 1080’s. So you might have to re-install the 367 drivers after if you install cuda 8 from a .deb package. If you install cuda from the .run file, it asks you if you would like to install the 362 drivers, and you can decline that to keep the 367 drivers if you install those first.

Thanks for the info.

I had tried re-installing 367 after installing Cuda 8, and that’s what seems to crash the X server. Possibly a conflict with Nouveau?

I’m putting together a new system from spare parts so I can keep working on this without messing up my main platform. Will try again over the weekend, and keep better track of what I’m installing, choices, etc.

Will report back…

I finally got it working under Linux Mint. Could not get it to work under Ubuntu 16.04.

Hi steve,

How did u get it to work?
I can’t make it to work yet. either getting driver version confilct or CUDA won’t work with 367.18


Hi Attic-

This all may be hardware specific.

First, get the 1080 hardware working with Linux Mint 17.3. Follow the Quickstart Guide guide to
– blacklist Nouveau
– regenerate kernel
– reboot to terminal (run level 3)

– install the 367.18 driver
– run xconfig
– reboot. You’ll have to plug your display into the 1080.

Now Mint should be working on your 1080.

– Install cuda 8.0, but do not install graphics drivers. (I think I booted into run level 3 to do this.)
– Reboot.

That should do it. Let me know if it works.

It can be frustrating, but the more time I spend poking around, the more I learn.


HI Stew!
I was able to make it work under ur instruction, one minor problem I found was that I can no longer use older GTX with 1080
some sort of conflict.

wonder if u had the same experience or not.

Thanks again


Glad you got it working!

I haven’t tried to mount my old 660ti along with the 1080— too afraid I’ll mess something up :)

Good luck!