GTX 570 no longer recognized by CUDA Addition of second GPU causes problems

I have a GeForce GTX 570 GPU installed in my machine. I installed the CUDA Toolkit and SDK (version 3.2), and everything worked fine. I ran a number of the examples (including building them) and they also worked fine.

In order to use Parallel Nsight, I installed a second GPU (an old Geforce 2) in a PCI slot to handle the display while the GTX 570 handles all of the GPU computing. In the BIOS, I set PCI to primary display, as I want the GeForce 2 to handle display. Now I cannot run any of the CUDA examples, and any calls to cudaGetDeviceCount return 0.

Both cards still show up in Device Manager, and are reported as working correctly. I performed a clean install of the latest drivers for the GTX 570 (266.58) and this did not correct the problem. Additionally, I cannot open the NVIDIA control panel. Clicking on it, either from the Windows control panel or the file location, does nothing.

Does anyone have any idea what might be happening here?

Cards that old (I think that’s from 2000?) aren’t supposed by the latest drivers, so it’s probably a WDDM versus not-WDDM mismatch.

That makes sense. I’ve only got one PCI express slot, so I needed something in plain PCI, and that ancient GeForce 2 was sitting around. The GeForce 6200 appears to be supported by the latest NVIDIA drivers and comes in a PCI variety at pretty low cost, so I’ll probably scoop up one of those. Thanks for your help.