GTX 660 with 3+ monitors

Bit of a dumb question really, but I want to be sure before I purchase. Does the GTX 660 support 3-4 monitors on Linux without having to fallback to crap like Xinerama, so I can get a 3-4 monitor setup with Composite enabled?

Yes, the GeForce GTX 660 should support up to four simultaneous displays.

Fantastic, thanks!

Anyone knows if Beryl now supports (multiple)desktop/s over 2048x2048 ?

Wasn’t Beryl merged back into Compiz several years ago?

Also, unless you’re talking about a different bug, that 2048x2048 limit was not set in stone. It was a value determined by your hardware. Specifically, the maximum texture size of the card. On some very low end cards, this was 2048x2048. According to the bug entry on the launchpad, some of the limits include:

Radeon Xpress 200M: 2048x2048
Radeon X1600/X1900: 4096 x 4096
Radeon HD 2400: 8192 x 8192
Radeon HD 2600/4670/4850/4870: 8192 x 8192
GeForce 7300/7600: 4096 x 4096
Quadro FX 4500: 4096 x 4096
GeForce 8600/880/9400/9600/120/130/285: 8192 x 8192
Quadro FX 4800: 8192 x 8192
i945: 2048 x 2048
GMA 950: 2048 x 2048
GMA X3100: 2048 x 2048

The 660 apparently has a limit of 16384 x 16384.

The desktop size limits are documented in the README:

Did you end up getting the 660? I’m thinking of upgrading to it as well, very curious about your experience with 3+ monitors on it.

Sorry, didn’t notice the update on this thread. I did get the 660, yes. It has been an excellent purchase, 3 monitors are working great in a now misnamed TwinView.

Confirmed. I have the 660 running four monitors at the same time on Debian unstable. Two 22" 1920x1080 panels and two 20" 1600x1200 panels.

The only awkwardness is since this does not make a perfect rectangle (22s up top, 20s on the bottom), I cannot drag windows across workspaces using the bottom 20" monitors. I have to move the window up to the 22" and drag across workspaces using the top stripe of monitors.

mishan, try disabling the ConstrainCursor option. With it disabled, it’s possible for your cursor to disappear into the dead zones outside of your monitors, but will allow you to move windows around the full span of your desktop.

Not understanding why I’m unable to run two monitors on my gtx 660. I have a dvi-i to vga converter and that seems to work fine. Trying to understand why the dvi-d to vga converter isn’t working. Both monitors are in function

Can you post your /var/log/Xorg.0.log file?

I’m having trouble with setting up my three monitors with Ubuntu 14.04 and Geforce GTX660.

1. Problem
My third screen (26" LG 16:9 Display) is not correctly recognized and therefore only possible to use in 4:3 mode. It is connected via the Displayport of the GPU with a Displayport to HDMI adapter and via HDMI to the screen.

2. Problem
The screen configuration (Positioning, resolution) is not stored. Neither when done via nvidia-settings nor when done with the “normal” display setting from Ubuntu.

Details about my setup:

  • Main Screen: Benq 24" (16:9), connected via HDMI
  • Second Screen: LG 19" (4:3), connected via DVI
  • Third Screen: LG 26" (16:9), connected via Displayport-HDMI adapter through HDMI (see above)
lspci | grep VGA 01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)

Ubuntu 14.04, installed Unity, but using Gnome desktop environment

Things I’ve tried so far:

  • Installing every driver listed under "additional driver", just to make sure that none of those work.
  • Installing the latest driver from the Nvidia Page, which leads me in a funny flashing tty, where I can only get rid of it again in recovery mode.
  • Installing Ubuntu Gnome 15.04 -> This actually somehow "worked". In the beginning all 3 Monitors where detected correctly, BUT everything was kinda laggy, and as soon as I started a program, the system would freeze to a point where I can move the mouse, but nothing else (Couldn't even go to TTY). Then I installed graphic drivers under Ubuntu Gnome 15.04. That lead me back to the same problem I have on Ubuntu 14.04.

I really appreciate every help, that leads me to a solution of the problem.
Cheers, SquweeZ
(link to ubuntu forum:
lint to reddit thread: