GTX 850M, "[opencl_init] could not get platforms: -1001" error in Darktable

I have an Acer Aspire V3-772G laptop with Intel integrated graphics and Nvidia GTX 850M, 2GB. I want to use OpenCL with the Darktable RAW developer (
I have installed The Nvidia 340.46 driver from xorg-edgers ppa, nvidia-settings, nvidia-prime and nvidia-cuda-toolkit. Glxgears runs fine:

hpb@hp-Acer ~ $ glxgears -info
GL_VERSION    = 4.4.0 NVIDIA 340.46
GL_VENDOR     = NVIDIA Corporation
21298 frames in 5.0 seconds = 4259.263 FPS
11973 frames in 5.0 seconds = 2394.407 FPS
11927 frames in 5.0 seconds = 2385.298 FPS

When I run “darktable -d opencl” to get info about Darktable’s OpenCL use i get this:

hpb@hp-Acer ~ $ darktable -d opencl
[opencl_init] opencl related configuration options:
[opencl_init] opencl: 1
[opencl_init] opencl_library: ''
[opencl_init] opencl_memory_requirement: 768
[opencl_init] opencl_memory_headroom: 300
[opencl_init] opencl_device_priority: '*/!0,*/*/*'
[opencl_init] opencl_size_roundup: 16
[opencl_init] opencl_async_pixelpipe: 0
[opencl_init] opencl_synch_cache: 0
[opencl_init] opencl_number_event_handles: 25
[opencl_init] opencl_micro_nap: 1000
[opencl_init] opencl_use_pinned_memory: 0
[opencl_init] opencl_use_cpu_devices: 0
[opencl_init] opencl_avoid_atomics: 0
[opencl_init] opencl_omit_whitebalance: 0
[opencl_init] trying to load opencl library: '<system default>'
[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] could not get platforms: -1001
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF.

My nvidia-bug-report.log.gz file is here:

I have tried every trick I could find now, nothing helps. I also tried via Bumblebee, which I would prefer if it worked, but nothing. I always end up with this “Could not get platform” error. I really hope that someone here can help me.

Hans Petter

Installed 14.10 today and had the same problem. It scared the hell out of me (especially after I spent, like, a week getting OpenCL to work in Darktable in 14.04).

Fortunately, some people out there are ahead of us:

Worked for me. Hope it fixes the problem for you, too. Let me know!

I will try as soon as I get some time. The only difference would be the nvidia-modprobe package. I keep fingers crossed…

Yes, that’s it! Now Darktable runs like a breeze. Thank you :-)

Great news! Glad I could help. :-)