GTX 950 + RTX 2060: No image on monitors connected to the second GPU (same setup works flawlessly on Windows)

I got GTX 950 and RTX 2060 installed. They both work on Windows and I get to move windows across the monitors connected to different cards on Windows.

On Linux I get only monitors connected to 2060 effectively working, even though all connected monitors show up in xrandr and KDE System Settings, monitors connected to 950 light up but show nothing but blank black screen (and I can’t move the cursor there even though xrandr output looks like I should be able to do that).

While messing around with nvidia-settings, nvidia-xconfig, xorg.conf and reading the driver README I could get to:

  • make monitors connected to 950 work while 2060 show blank screen (simply by making 950 the Device0 in xorg.conf, it seems)
  • two different X screens (:0.0 and :0.1) working (but of course the desktop environment and input devices worked on :0.0 only, but I could start DESKTOP=:0.1 xterm on the second set of monitors)
  • all blank screens and segfault for every app I tried to start when trying to use Xinerama

So I resorted back to the default state of having no xorg.conf as most usable for now.

I use xmonad as a window manager with no compositor, but I also tried using kwin to no effect.

Is this setup supposed to be working? I hope it is, as it works on Windows on the exact same machine.

xrandr output, Xorg.0.log and other

Started with no /etc/xorg.conf or xorg.conf.d/*.conf files:

xrandr.txt · GitHub

Xorg.0.log · GitHub

lspci | grep VGA:

03:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 950] (rev a1)
08:00.0 VGA compatible controller: NVIDIA Corporation TU104 [GeForce RTX 2060] (rev a1)

Driver Version: 455.23.04 (as reported by nvidia-smi)

uname -a:

Linux futpib-desktop 5.8.12-arch1-1-pds #1 SMP PREEMPT Mon, 28 Sep 2020 17:49:34 +0000 x86_64 GNU/Linux

same problem here : Dual nvidia, triple monitor xorg configuration

just bumping to create attention to the problem . .

1 Like

Updated the driver to 455.28 to no effect. Here is the new nvidia-bug-report.log.gz (1.6 MB) (now with -logverbose 6, sorry for not doing it originally)