GTX1050 blank, freeze after resuming from suspend

I recently replaced a broken GTX560 with a GTX1050 and it works great however, after resuming from suspend the screen doesn’t turn on and the system is frozen and can’t even be halted (except for a hard reboot). This is the same behavior noted in many posts on this site (which now seem to be locked). I have followed all the suggestions in the long other posts and cannot figure this out. I have the problem with the 381 and 384 drivers on kernel 4.12.1. I have tried blacklisting nouveau, various kernel boot commands, replacing nvidia.conf, standing on my head and rubbing my stomach and it still doesn’t work. Nothing strange in xorg.log or dmesg. Is this still a driver bug? Thanks

Minor update: So it seems with the 384 drivers, the system never resumes and the monitor never turns back on. The system requires a hard reset. With the 381 drivers, the system can resume if there is not a lot of time between suspend and resume. If there is a lot of time, the monitor will turn on and there is some console messages, but when X tries to start, the system freezes the same as the 384 driver and a hard reboot is necessary. I’m fairly convinced this is a driver issue, and I can’t figure anything else out to try.

I have been having the same issue with this for a long, long time exactly as you described. I use a Zotac 1050 GTX mini. No fixes from any previous thread seem to work.

Can any of you ssh into system while frozen? Run then.

So I tried to ssh into the frozen system this morning and it’s not possible. For what it’s worth, it seems to be freezing less often now (about 1 in 4 times as opposed nearly every time). Seems to have gotten better when I updated upower. I also use an dvi switch on my monitor and it might be looking for a monitor before the switch finds the active output? I’ll try to ssh in quicker next time it happens and see if it’s possible…