H5py build failing during Tensorflow install

Good Evening,

I was following the instructions here to try and install TensorFlow to my jetson nano in a virtual environment.

I tried to upgrade to jetpack 5.5, but I am not sure how to tell if it actually worked, which if it didn’t doing that may solve the issue I am seeing.

When pip tries to build and install h5py, I see an error message about

ERROR: Command errored out with exit status -4:
command: /home/user/Code/TensorFlow/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-go1xiwnd/h5py_df959324472048b0bac6e0ddb14b4a65/setup.py'"'"'; __file__='"'"'/tmp/pip-install-go1xiwnd/h5py_df959324472048b0bac6e0ddb14b4a65/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-1vdd9rok
cwd: /tmp/pip-install-go1xiwnd/h5py_df959324472048b0bac6e0ddb14b4a65/

which is a bit cryptic to me, but I was hoping to get some advice on how to hopefully solve this problem so that the install goes correctly.

Thanks!

Hi,

Could you share the complete error log with us?

We can install h5py with the following commands:

$ sudo apt-get install python3-pip
$ sudo apt-get install libhdf5-serial-dev hdf5-tools libhdf5-dev 
$ pip3 install cython
$ pip3 install h5py==2.10.0

Thanks.