Trouble installing tensorflow 2.6-cannot install h5py-3.1.0

Into latest jetpack 4.6

1 Like

hi, @pedro.valdes.guzman. Can please refer this documentation Installing TensorFlow For Jetson Platform :: NVIDIA Deep Learning Frameworks Documentation. Hope this will help you.

Thank you

ain’t actual, I’m taking about jetpack 4.6, the latest, this didn’t helped me. Thanx

Sorry, I was missing. I’ll try once more.

I am having the same problem; attempting to install tensor into JP 4.6 on Jetson Nano 2GB using these instructions; Installing TensorFlow For Jetson Platform :: NVIDIA Deep Learning Frameworks Documentation yields these errors

sudo env H5PY_SETUP_REQUIRES=0 pip3 install -U h5py==3.1.0
  Downloading h5py-3.1.0.tar.gz (371 kB)
     |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 371 kB 2.5 MB/s 
  Installing build dependencies ... error
  ERROR: Command errored out with exit status 1:
   command: /usr/bin/python3 /usr/local/lib/python3.6/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-6uer_3bk/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- setuptools wheel
       cwd: None
  Complete output (29 lines):
  Traceback (most recent call last):
    File "/usr/lib/python3.6/runpy.py", line 193, in _run_module_as_main
      "__main__", mod_spec)
...
    File "/usr/local/lib/python3.6/dist-packages/pip/_vendor/tenacity/__init__.py", line 26, in <module>
      from concurrent import futures
    File "/usr/local/lib/python3.6/dist-packages/concurrent/futures/__init__.py", line 8, in <module>
      from concurrent.futures._base import (FIRST_COMPLETED,
    File "/usr/local/lib/python3.6/dist-packages/concurrent/futures/_base.py", line 357
      raise type(self._exception), self._exception, self._traceback
                                 ^
  SyntaxError: invalid syntax
  ----------------------------------------
...
ERROR: Could not find a version that satisfies the requirement h5py==3.1.0 (from versions: 2.2.1, 2.3.0b1, 2.3.0, 2.3.1, 2.4.0b1, 2.4.0, 2.5.0, 2.6.0, 2.7.0rc2, 2.7.0, 2.7.1, 2.8.0rc1, 2.8.0, 2.9.0rc1, 2.9.0, 2.10.0, 3.0.0rc1, 3.0.0, 3.1.0)
ERROR: No matching distribution found for h5py==3.1.0
1 Like