Nvidia/jetson Tensorflow installation failed


Just downloading the sd card image from JetPack SDK 4.6.1 | NVIDIA Developer , burn it and started the jetson nano developper kit. Finished the ubuntu configuration steps. Did nothing else.

Opened a terminal and followed steps described in Official TensorFlow for Jetson Nano! , Python 3.6+JetPack4.6.3
The following command failed:
sudo pip3 install -U numpy==1.19.4 future mock keras_preprocessing keras_applications gast==0.2.1 protobuf pybind11 cython pkgconfig packaging

Building wheel for h5py (pyproject.toml) … error
ERROR: Command errored out with exit status 1:
Error compiling Cython file:

License: Standard 3-clause BSD; see “license.txt” for full license terms

and contributor agreement.

from .defs cimport *

from ._objects cimport class ObjectID

h5py/h5t.pxd:13:23: Expected an identifier


Traceback (most recent call last):
File “/home/edf/.local/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py”, line 363, in
File “/home/edf/.local/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py”, line 345, in main
json_out[‘return_val’] = hook(**hook_input[‘kwargs’])
File “/home/edf/.local/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py”, line 262, in build_wheel
File “/tmp/pip-build-env-0ufsaci5/overlay/lib/python3.6/site-packages/setuptools/build_meta.py”, line 231, in build_wheel
wheel_directory, config_settings)
File “/tmp/pip-build-env-0ufsaci5/overlay/lib/python3.6/site-packages/setuptools/build_meta.py”, line 215, in _build_with_temp_dir
File “/tmp/pip-build-env-0ufsaci5/overlay/lib/python3.6/site-packages/setuptools/build_meta.py”, line 158, in run_setup
exec(compile(code, file, ‘exec’), locals())
File “setup.py”, line 183, in
cmdclass = CMDCLASS,
File “/tmp/pip-build-env-0ufsaci5/overlay/lib/python3.6/site-packages/setuptools/init.py”, line 153, in setup
return distutils.core.setup(**attrs)
File “/usr/lib/python3.6/distutils/core.py”, line 148, in setup
File “/usr/lib/python3.6/distutils/dist.py”, line 955, in run_commands
File “/usr/lib/python3.6/distutils/dist.py”, line 974, in run_command
File “/tmp/pip-build-env-0ufsaci5/overlay/lib/python3.6/site-packages/wheel/bdist_wheel.py”, line 299, in run
File “/usr/lib/python3.6/distutils/cmd.py”, line 313, in run_command
File “/usr/lib/python3.6/distutils/dist.py”, line 974, in run_command
File “/usr/lib/python3.6/distutils/command/build.py”, line 135, in run
File “/usr/lib/python3.6/distutils/cmd.py”, line 313, in run_command
File “/usr/lib/python3.6/distutils/dist.py”, line 974, in run_command
File “/tmp/pip-install-522owmfu/h5py_0256cb7a7f6c46a49ac27644a79ff507/setup_build.py”, line 171, in run
File “/tmp/pip-build-env-0ufsaci5/normal/lib/python3.6/site-packages/Cython/Build/Dependencies.py”, line 1134, in cythonize
File “/tmp/pip-build-env-0ufsaci5/normal/lib/python3.6/site-packages/Cython/Build/Dependencies.py”, line 1301, in cythonize_one
raise CompileError(None, pyx_file)
Cython.Compiler.Errors.CompileError: /tmp/pip-install-522owmfu/h5py_0256cb7a7f6c46a49ac27644a79ff507/h5py/_conv.pyx

ERROR: Failed building wheel for h5py

Please help me installing tensorflow

Thanks in advance

I have the same issue but in Windows 10. I think it has to do something with new Cython version breaking something.


Could you check if you are facing the same issue as below:



Have you fixed this issue?
We got some info from our internal team for this issue.

Please update to a newer version of h5py to solve this issue.
Specifically, you will need a version that includes the below commit:

So please use 3.8.0 or newer.

I did a new fresh Windows 10 installation, then installed python and everything from scratch, and it worked this time. Probably unnecesary to do clean Windows installation, but I planed it anyways soon.

But it seems does not support 3.8

I tried using python3.6 as provided by default in the official image.
Is there any chances you’ll provide a new image on Ubuntu 20.04+ with python3.8 or 3.9 support ?

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.