Failed building wheel for h5py on Jetpack 4.6.1 on Xavier NX

Hi, I encountered a problem when I tried to install Tensorflow to my fresh Jetpack 4.6.1 on Xavier NX. I followed the steps on this site: Installing TensorFlow for Jetson Platform :: NVIDIA Deep Learning Frameworks Documentation. All installations are OK until coming to this step: $ sudo env H5PY_SETUP_REQUIRES=0 pip3 install -U h5py==3.1.0. An error occurred in this step:
Building wheel for h5py (pyprlject.toml) … error
Failed to build h5py
How to solve this problem?
Can I proceed to install Tensorflow without h5py?

Hi,

Yes, could you proceed to install the package to see if any issue?
Thanks.

Hi,
I tried, with 2 attempts:
sudo pip3 install --pre --extra-index-url Index of /compute/redist/jp/v50 tensorflow (this is the original command)
and
sudo pip3 install --pre --extra-index-url Index of /compute/redist/jp/v46 tensorflow (after 1st failure, I tried this command because I’m now using Jetpack 4.6.1)
But both failed.
Please advise.

Hi,
Can you please reply? I’m waiting for your solution to this issue.

Hi,

Could you share more details about the failure?
Do you get any error output can share with us?

More, we also have a container that has TensorFlow pre-installed.
Maybe you can use it directly for simplicity.

Thanks.