Has anyone tried to read GPU utilization with CUDA 4.0?

I have updated my system to CUDA 4.0 yesterday. Previously I was using CUDA 3.2 and I can read the GPU utilization through ‘nvidia-smi -a’. However, after my update to CUDA 4.0, the utilization returned by ‘nvidia-smi -a’ is N/A. Has anyone tried it and had the same problem? Or I did something wrong?

Thanks.

I have checked my installation - confirming the same N/A output.

Thank you so much!

I have tested on a high end server with Tesla T10. ‘nvidia-smi -q’ can return the correct utilization.

My card is an ancient one, GeForce 8800 GTX. What about urs?

Same here, it works with the Teslas but not with the Geforce (GTX 460 & 580).

On the Teslas, we can see the GPU utilization, power draw, etc…
Lots of N/A on the gamer’s cards.

Has NVIDIA already been on the track of giving up the previous CUDA enabled devices (in another word, the computation capability 1.0 devices?)

They didn’t test new development tools on previous products but just release them?

By the way, since nvidia-smi with driver version 270.18 can still give me correct utilization reading, I have even tried to link nvidia-smi shipped in 270.18 driver package with 270.18 libraries and run this modified nvidia-smi locally. But it returns me that the nvidia-smi kernel version is different from driver version (as we know, CUDA 4.0 is with driver version 270.40 and up). Is it a crazy method? Anybody who has tried it before?

Thanks :thanks:

Has anyone found some workaround for reading CPU/Memory utilization on GeForce cards with CUDA 4.0?

A GPU top utility that could show GPU load as well as which process(es) are currently using a particular GPU would be very useful…

Is this something that could be done with the new CUPTI API?

/Lars

I also have the same problem since upgrading to CUDA 4.0. I was reading %utilization and Mem_usage using conky but I get N/A.
A manual query of nvidia-smi shows that it returns N/A on most of the fields. Since this doesn’t seem directly related to any new features in CUDA 4.0 fixing it might be simple.

Can someone from NVIDIA acknowledge that they know about this bug?