nvidia-smi from cuda driver 270.26 not working

The nvidia-smi tool shipped with the beta driver (270.26) doesn’t seem to work. If I run “nvidia-smi -L” (to just list devices) I get:

Unable to determine the product UUID for gpu 0: N/A

I’m on a RHEL system (5.6) with a GTX580.

Sorry I am not sure about your question.

But I heard if you use nvidia-smi on 270 later driver, it will give actually memory usage instead of percentage of memory usage. Is this possible for you to post the result nividi-smi -a returns after you fixed current problem? Really grateful!

I’m having similar problems with nvidia-smi and GTX 580s using the 4.0rc driver (see post in CUDA Linux).

This worked fine under CUDA 3.2. Is NVIDIA disabling compute mode configuration etc for GeForce cards with CUDA 4.0?


From the CUDA 4.0RC man page for nvidia-smi, “NVSMI provides diagnostic information for NVIDIA Tesla and Quadro devices.” This is a sad day.

The manpage has always said that. Right back at least to the 170 series drivers when it said

So I wouldn’t yet read anything into that.

That’s good to hear. I just purchased a machine with 3x GeForce cards with hopes of using it for multi-gpu development. We didn’t have the $6k+ for a 3x C2050 system.