Have to use nomodeset after cuda install

I have installed the cuda 9 with 384 driver on an ubuntu 16.04 where a M2000 is used. Prior to installing the driver, I appended “nomodeset” to kernel parameter in order to boot the machine. Then I entered the console and installed the driver and it was successful.

After a reboot, if I drop the “nomodeset”, still the ubuntu stuck with messy picture. Again I have to use “nomodeset” in the kernel parameters.

Is that normal? I don’t think so.

It may be as a result of not properly removing the nouveau driver. You may want to read the linux install guide.

Well I read that before installation. Maybe I missed something.
From what I saw during the installation of cuda driver, it automatically disables nouveau. Otherwise it won’t be able to install the driver. Isn’t that correct?

If you did a runfile install, it does not automatically disable nouveau.

Anyway it was just a suggestion. If you don’t want to investigate it, that’s OK. I don’t know with 100% certainty exactly what is happening in your case.

OK. Meanwhile, what happens if I still use nomodeset in the kernel parameter?
While I have to pass nomodeset, I can see full resolution screen and the nvidia x server setting shows correct information, e.g. device name, driver version, temperature and etc.

try googling “linux nomodeset” or similar. You’ll find descriptions of what it does.