Having to manually install "cuda-samples" in Arch Linux and having a difficult time

I’ve been trying to install CUDA’s tools. CUDA is installing, but missing some files. Before I proceed, I’ll mention that I found my CUDA installation not to be in the normal place, it’s in /opt/cuda.

One example is:

/some/irrelevant/path/src/cuda/cuda.cpp:1:10: fatal error: helper_cuda.h: No such file or directory
    1 | #include <helper_cuda.h>

I ran find / -name helper_cuda.h and it wasn’t in my system which led me on a wild goose hunt. I ended up finding a file in /opt/cuda/samples: README_CUDA_Samples.txt and inside it is:

CUDA samples have moved! Please find up-to-date CUDA samples on our GitHub repository:

So I cloned the repo and found the helper_cuda.h file in it. I ran the Makefile and it doesn’t look like it had errors, but I’m not sure. I tried running make install and it says it has nothing to do, but the make ran without error(that I saw). I manually copied the Samples and Common directories to /opt/cuda/ but it’s not helping. I don’t know if I copied them to the incorrect directory.
Basically it looks like I’m stuck installing it manually and could use a hand to point me in the right direction.

I fixed my issue for one of the reasons I was trying to by making the directory: /opt/cuda/samples/common/inc and adding the contents of cuda-samples/Common to /opt/cuda/samples/common/inc. This fixed the helper_cuda.h error.