HDMI external monitor not working on ubuntu + kde plasma

I connect external monitor to hdmi port but nothing happens

I’ve tried everything, I’ve already installed the 470 and 390 driver.
I also tried on nvidia-drm.modeset=1.
nothing worked

Driver

$ lspci | grep -i nvidia                                                                                                                                                                                        

01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10fa (rev a1)

LInux details

$ uname -m && cat /etc/*release                                                                                                                                                                                        

x86_64
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.3 LTS"
NAME="Ubuntu"
VERSION="20.04.3 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04.3 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal


Error on run nvidia-smi

$ nvidia-smi                                                                                                                                                                                                    

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.


Grub setting


$ cat /etc/default/grub 

...
GRUB_CMDLINE_LINUX_DEFAULT="quite splash"
...

Installed server driver

xserver-xorg-video-nvidia-510/unknown,now 510.47.03-0ubuntu1 amd64 [installed,automatic]
  NVIDIA binary Xorg driver

nvidia-bug-report.log.gz (111.5 KB)

Please disable secure boot in bios or enable module signing.

it worked like magic. I just disable security boot

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.