HDMI monitor not detected Ubuntu 20.04

Hello,

My HDMI monitor is not detected since yesterday, when I switched on my computer. I have tried some solutions I’ve read in this forum, but no luck. It would be great if someone could help me with this.

Thanks!
nvidia-bug-report.log.gz (318.3 KB)

Hi @david.jimenez.mirayo and welcome to the developer forums.

From the bug report log there is no real issue visible. HDMI is enumerated and there are no errors logged. Also the NVIDIA GPU is correctly detected and drivers seem to be ok.

How is HDMI connected to your Notebook? Is it a native HDMI connector or is there any kind of adapter?

First of all I would check all cables, adapters that they are ok and plugged in correctly.
Then if possible try to connect a different external monitor to double check.
Also make sure to do a “cold” reboot of the machine, meaning shut down and restart.

If that does not fix things, try installing any pending Ubuntu updates as well as updating the NVIDIA driver. The latest recommended for Ubuntu 20.04 is version 510 from the additional driver section.

I hope this helps!

Thanks for your answer.

HDMI is connected through an adapter. I have tried with different external monitors, adapters and cables. I have also done the “cold” reboot several times with no luck.

It began to happen just after installing an Ubuntu update, so system is updated, and I have just installed the recommended Nvidia drivers and same result.

Hi again,

sorry for being silent for so long.

Did anything change in your situation in the meantime?

If not, can you specify a bit what kind of adapter you are using?

Also, please run nvidia-smi and share the output here, as well as a fresh nvidia-bug-report.log.gz.

Thanks!

Hi!

Thanks for your answer. Unfortunately I’m still having the problem.

I have tested it with three different adapters that work with other computers. I’ve also tested it with three different screens and a lot of cables with no luck.

It’s it happening in a HP computer that only have Ubuntu 20.04 installed. But, by mistake I pressed F9 during the boot and now it try to start on Windows even when this OS is not installed in the computer and I now I need to press F9 in every boot to start on Ubuntu. I remember that the issue with the screen started to happen when I made this. I don’t if this may have something to do.

I send you and updated verison of nvidia-bug-report.

When I try to run nvidia-smi y receive this: Failed to initialize NVML: Driver/library version mismatch.

Thanks very much for your help.

nvidia-bug-report.log.gz (137.4 KB)