HELP me with PGC-W-0267 warning

My Platform Mac OS 10.8.2
CUDA 5.0 environment

My test.c file
#include <stdio.h>
#define N 1000000

int main(void) {
double pi = 0.0f; long i;
#pragma acc parallel loop
for (i=0; i<N; i++) {
double t= (double)((i+0.5)/N);
pi +=4.0/(1.0+t*t);
}
printf(“pi=%16.15f\n”,pi/N);
return 0;
}

when issue command
$pgcc -ta=nvidia,cc20 -Minfo=accel test.c

PGC-W-0267-#warning – “Unsupported compiler detected” (/usr/include/sys/cdefs.h: 81)
main:
6, Accelerator kernel generated
6, CC 2.0 : 23 registers; 0 shared, 60 constant, 0 local memory bytes
7, #pragma acc loop gang, vector(256) /* blockIdx.x threadIdx.x */
9, Sum reduction generated for pi
6, Generating compute capability 2.0 binary
PGC/x86-64 OSX 12.9-0: compilation completed with warnings
test.c:38:no such instruction: vzeroupper' test.c:61:no such instruction: vzeroupper’
test.c:65:no such instruction: vzeroupper' test.c:77:no such instruction: vzeroupper’
test.c:91:no such instruction: vzeroupper' test.c:104:no such instruction: vzeroupper’
test.c:118:no such instruction: vzeroupper' test.c:138:no such instruction: vzeroupper’
test.c:159:no such instruction: vzeroupper' test.c:170:no such instruction: vzeroupper’
test.c:173:no such instruction: vmovsd -48(%rbp), %xmm0' test.c:174:no such instruction: vmovsd %xmm0, -56(%rbp)’
test.c:180:no such instruction: vzeroupper' test.c:182:no such instruction: vzeroupper’
test.c:185:no such instruction: vmovsd -56(%rbp), %xmm0' test.c:186:no such instruction: vmulsd .C00398(%rip), %xmm0,%xmm0’
test.c:188:no such instruction: vzeroupper' test.c:194:no such instruction: vzeroupper’
test.c:1301:no such instruction: `vzeroupper’

Thanks a lot!

Hi dr.bennix,

I asked PGI Customer Support to send you an updated cdefs.h and siterc file for Mountain Lion.

  • Mat

I am having the same problem

On October 29, I sent mail to dr.bennix with cdefs.h and siterc files.

I have attached two files that should get around your problem until
we get it fixed in a release.

Replace the /opt/pgi/osx86-64/12.9/include/sys/cdefs.h with
the attached file. It will solve the cdefs.h problem.

Store the attached siterc file as
/opt/pgi/osx86-64/12.9/bin/siterc
to eliminate the ‘vzeroupper’ messages.

I will send them again

I am also having the same problem.

matt@pontus:diffFst$ pgcc -c cDoDiffFst.c
PGC-W-0267-#warning --  "Unsupported compiler detected" (/usr/include/sys/cdefs.h: 81)
PGC/x86-64 OSX 12.9-0: compilation completed with warnings
matt@pontus:diffFst$ pgcc --version

pgcc 12.9-0 64-bit target on Apple OS/X -tp nehalem 
Copyright 1989-2000, The Portland Group, Inc.  All Rights Reserved.
Copyright 2000-2012, STMicroelectronics, Inc.  All Rights Reserved.

I have that too.

Should this matter be solved by now or is it still the same problem, if so please send me the fixed file as well.

We had to undefined the variable that checks the gcc version.

Download the 13.3 release and pull the cdefs.h file out of there.

Or send mail to trs@pgroup.com and we can send it to you.

Another workaround.
Add –D__GNUC__ to your compile line.


dave