Help, please. How do I manually download L4T and flash it manually for Xavier AGX? (Using Ubuntu 20.04)

Could someone point me in the right direction for instructions to be able to:

  • Manually download the latest L4T
  • Flash it to my Xavier AGX
    The SDK manager just stops at an early stage on Ubuntu 20.04 and doesn’t move on from there.
    (see image)
    Everything else seems like it will work. (device is detected, etc.)

An Ubuntu 20.04 host is not yet supported (the SDKM works, but the software for Jetson install will be added at the next release and does not work with Ubuntu 20.04 host and current release). FYI, JetPack/SDKM is just a front end to what is actually flashed. “L4T” is what gets flashed, and is just Ubuntu 18.04 plus NVIDIA hardware accelerated drivers. So what you want is the L4T install without the GUI (which does tend to work on many different flavors and releases of Linux…most of the dependencies are for JetPack/SDKM and not for flash). My recommendation is to use an Ubuntu 18.04 host PC if you can.

To see releases of L4T go here:
https://developer.nvidia.com/embedded/linux-tegra-archive

I of course will recommend the most recent release, which at this time is R32.6.1. From there you will download the “driver package” listed for your AGX (this is essentially the flash software on command line without needing JetPack/SDKM) and the “sample root filesystem” (which is purely Ubuntu 18.04). Assuming you have downloaded these the steps are:

  1. Unpack the driver package without using sudo. This produces a “Linux_for_Tegra/” subdirectory.
  2. Go to “Linux_for_Tegra/rootfs/”.
  3. Unpack the sample rootfs here using sudo (the content needs root permission to unpack correctly).
  4. cd back to “Linux_for_Tegra/” and install the NVIDIA components to the rootfs (this does use sudo):
    sudo ./apply_binaries.sh
  5. This software is now ready to flash as many times as you want without repeating any of the above.

A typical command line flash, if the Jetson is connected in recovery mode with the USB-C connector, would be this from “Linux_for_Tegra/”:
sudo ./flash.sh jetson-xavier mmcblk0p1

You’ll want to have a monitor connected to the Jetson so you can perform the first boot setup (though a serial console can do this too).

Note that this only installs the operating system. None of the options, e.g., CUDA or multimedia content is part of this. You would then need to install these yourself, e.g., using the apt-get mechanism. Assuming the NVIDIA repository is available (and it should be), then you could examine the output of this:

apt search nvidia
apt search libnv
apt search l4t

Keep in mind that dependencies mean that if you install an NVIDIA package which uses a library, then dependencies will install this for you (you don’t necessarily have to install each package one at a time…installing some packages will trigger installing others without you having to specify). Also, not all of those packages will be missing from your system since the earlier “sudo ./apply_binaries.sh” would have installed things the operating system depends on. I suggest starting with installing this since it is sort of at the heart of other optional packages:

# This just gets the existing content up to date:
sudo apt update
sudo apt upgrade
# Now install CUDA:
sudo apt-get install nvidia-l4t-cuda

Using JetPack/SDKM is better since it knows about all that applies and will neither miss packages, nor install unneeded content. Also, note that package “nvidia-l4t-jetpack” might install more than you counted on and fill the filesystem. Don’t install this latter package unless you need it.

I installed QEmu and am running Ubuntu 18.04 there for the SDK Manager to work. It connects to the device and so on.

But it seems like I have much worse problems now. I tried to flash to NVME, but that didn’t work. It always stopped at around 35% with errors. Retried about 5-6 times. I have a Samsung EVO 1 TB. (manual mode)
Now I tried to flash to eMMC, and it fails with “device is in a bad state, restart it in recovery mode” or something similar, and it also fails quite quickly afterward. (manual mode)

I will try your methods to try to recover the device.

I hooked up a monitor and mouse, and it was actually booting into Ubuntu. So I was able to get it set up. So all is good. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.