How can I flash my Xavier with Jetpack v4.2.0?

Hello,

I have a camera kit which requires l4t version 32.1. As far as I can tell, the newest version of Jetpack with l4t 32.1 is v4.2.0. I tried running sdkmanager with the --archivedversions flag, but the oldest version listed is 4.2.2 which has l4t 32.2. I also tried downloading and using sdkmanager from the jetpack 4.2 release page, but that version of sdkmanager won’t even do anything until you update it.

Is it still possible to flash the Xavier with Jetpack 4.2.0 using the sdkmanager? I know I can download the 32.1 source and compile it myself to flash with the command line utility, but I’d really like to avoid doing that. It looks like I’d basically have to figure out proper versions and install all the components of Jetpack manually instead of being able to use the sdkmanager.

Thanks for any help with this.

You can find L4T 32.1 in the L4T Archive | NVIDIA Developer

Download the Driver Package and the Sample Root File system and follow the Developer guide for flashing the operating system : https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3261/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/quick_start.html#wwpID0E05C0HA

Thanks for the response!

Seems like then if I want the rest of the components of jetpack (cudnn, tensorrt, opencv, etc) I’ll have to install everything manually?

After flashing L4T 31.1 you can log in to AGX and install JetPack by
sudo apt-get install nvidia-jetpack

Fantastic, thanks!

Unfortunately, it seems like jetpack isn’t available through apt for l4t 32.1.

See here https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html#install-jetpack where it says that apt can be used for l4t 32.3.1 or higher.

I’ve found the jetpack 4.2 archive, but I can’t find links to any documentation that would help me install the additional components of Jetpack after flashing the board. I also can’t find any sort of compatibility chart or release notes that list the exact versions of all the components in that particular release of jetpack.

I would be very grateful if someone could link me to the appropriate documentation.

Just some trivia: Those earlier releases had some (or all if old enough) content installed as loose files simply unpacked to the system, and thus could not be updated with the apt package mechanism. It was at R32.3.1 that the content migrated to the apt package mechanism.

On earlier releases there would have been an associated “repository.json” file. That file contained a base URL, and other suffixes to the URL to find individual files. If you have that, then you might be able to figure out where to download individual “extras”, but I wouldn’t bet on it since those server URLs are likely moving targets and no longer active. Thus every older release needing some sort of OTA update (or using the apt mechanism) likely needs a completely manual install.

Ok, so as far as anyone is aware, is there any way to know what’s actually installed after I’ve flashed the rootfs? I haven’t been able to find any documentation that’s specifically from Jetpack 4.2, so I have no idea what components are supposed to be included in it. The archived release page https://developer.nvidia.com/jetpack-4_2 mentions e.g. tensorRT, but I haven’t been able to find any indication that tensorRT is installed anywhere in the rootfs.

Also, I’m not sure if you’re saying that “repository.json” would be included somewhere in the rootfs for l4t 32.1, but I can’t find any file by that name.

At this point, I’d be happy to hunt down and install manually all of the components of Jetpack, but I cannot find any documents specifying what those components should be or what versions are compatible with L4T 32.1.

Rootfs only provides necessary filesystem to boot up into ubuntu. These do no exist in rootfs.

You still need jetpack4.2/sdkmanager to help you install CUDA/TensorRT.

Ok. When I realized that I would be unable to install Jetpack 4.2 with the most recent sdkmanager (the oldest version available is 4.2.2) I downloaded the sdkmanager listed on the 4.2 archive page. However, when I attempt to run that version of the sdkmanager, I get a popup that says the sdkmanager I have installed is out of date, and I have to update in order to run it. I haven’t verified, but I assume that if I update the 4.2 sdkmanager in order to run it, I will have the original problem, of 4.2 Jetpack not being available through the sdkmanager.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.