JetPack 4.2.1 - L4T R32.2 release for Jetson Nano, Jetson TX1/TX2, and Jetson AGX Xavier

NVIDIA is excited to have released JetPack 4.2.1 and L4T R32.2, the latest production release including new features and improvements for Jetson Nano, Jetson TX1/TX2, and Jetson AGX Xavier! See the Key Features for a list of highlights, including:

  • Headless initial system configuration via the flashing USB port or UART
  • NVIDIA Indicator Applet for nvpmodel performance power mode switching
  • The Jetson Zoo repository of popular open-source packages and DNN models
  • Support for Ubuntu 18.04 aarch64 for Jetson TX1
  • Support for DeepStream 4.0 and ISAAC 2019.2
  • New beta features:
    • Xavier DLA support for INT8 in TensorRT
    • NVIDIA Container Runtime with Docker Integration

The NVIDIA SDK Manager can be used to install JetPack 4.2, including developer tools with support for cross-compilation.

For more information, please refer to the JetPack Release Notes and L4T Release Notes.

JetPack 4.2.1 components:

  • L4T R32.2 (K4.9)
  • Ubuntu 18.04 LTS aarch64
  • CUDA 10.0.326
  • cuDNN 7.5.0.66
  • TensorRT 5.1.6.1
  • VisionWorks 1.6
  • OpenCV 3.3.1
  • Nsight Systems 2019.4
  • Nsight Graphics 2019.2
  • SDK Manager 0.9.13

Download JetPack…https://developer.nvidia.com/embedded/jetpack
Release Notes…https://docs.nvidia.com/jetson/jetpack/release-notes/index.html
L4T Release Notes…https://developer.nvidia.com/embedded/dlc/Tegra_Linux_Driver_Package_Release_Notes_R32.2.0_GA.pdf

Thanks dusty! and I have question. Is Tensorflow for Jetpack supports to TX1? I’m qurious why TX1 is excluded from recent update. It has almost same specification as Jetson nano.

I’m not sure that TensorFlow is tested on Jetson TX1, but you may be able to install it, as it uses same CUDA compute capability (5.3) as Jetson Nano.

Thanks dusty! I tried last night and it worked although I am not sure whether tensorflow uses its resources fully. Thus starting from next release, I hope tensorflow for jetpack officially supports Jetson TX1.

Have a nice day!

How to install SDK Manager on Ubuntu without using “sudo”?
We have shared computers and installing third parties outside of user home directory is a very bad idea.
I see that sdkmanager_0.9.14-4961_amd64.deb contains files in /opt and /usr,
which is not allowed.
In the past I installed JetPack, like JetPack-L4T-3.3-linux-x64_b39.run, in my own directory without sudo.

So, is it possible to install SDK Manager without sudo?
If not, then how can I download JetPack 4.2.2 .run, like it used to be?

Thank you

Features of creating the image to flash, along with creating loopback devices, means it is mandatory for the SDK Manager “.deb” file to be installed with “sudo”, and then the actual “sdkmanager” binary to be run as a regular user, but with a password added for sudo access.

Keep in mind that an entire Linux filesystem is being created, and that permissions on those files must be correct for an independent operating system. Only root can create root-owned files. Only root can create loopback devices used with the image.

Note that installing the SDKM “.deb” merely makes the “sdkmanager” application available. The actual flash content is in the user’s “~/nvidia/nvidia_sdk/” directory, and is not spread out to other users.

All flash software from all versions of L4T going back over more than a decade have required “sudo” to create images and to create loopback devices.

Yes, I do not mind to use sudo to access some devices, like USB flash adapter.
My question was specifically about installation. Installation to /opt or /usr is not allowed.

So far I tried to simply extract :
dpkg -x sdkmanager_0.9.14-4961_amd64.deb $HOME/installs/nvidia_sdk_manager_extracted

Now I have $HOME/installs/nvidia_sdk_manager_extracted/opt and $HOME/installs/nvidia_sdk_manager_extracted/usr
Then

$HOME/installs/nvidia_sdk_manager_extracted --cli install --user dmitri@prenav.com --logintype devzone
–product Jetson --version GA_4.2.2 --targetos Linux --host --target P2888 --flash all

So far it appears that it downloaded OK
$HOME/nvidia/nvidia_sdk/JetPack_4.2.2_Linux_GA
and
$HOME/nvidia/nvidia_sdk/JetPack_4.2.2_Linux_GA_P2888

What I am missing?
Was “sudo apt install ./sdkmanager-[version].deb” not necessary?

If you just want to flash, and you are not interested in extra package installs, then it is easy to do so without going outside of the home directory (though you still need sudo access). This is just the driver package plus sample rootfs (neither of which is a “.deb”…they’re just compressed tar files). The two of those are used together to flash on command line. The GUI is just a front end to this, but the GUI is the method for adding extra packages. Are you ok with just flashing and not installing extras?

FYI, if you have a clone of a system with everything you need, then command line flash can use that clone (the clone should be from the same release as the driver package doing the install). Getting that first system with the extra “goodies” (like CUDA) will probably require JetPack/SDKManager install to “/opt”. You can manually get around this, but there is a learning curve involved and a lot of time to install packages without JetPack. I have in fact not tested this under SDK Manager, and I don’t know if the previous steps to manually get packages from JetPack will work with SDKM.

The “sudo apt install ./sdkmanager-[version].deb” is what installs the sdkmanager app and running sdkmanager is what produces the “~/nvidia/nvidia_sdk/” content. So if you have the executable “sdkmanager”, then someone has already installed it (but you don’t know if the version is what you want).

FYI, this is a link to the various L4T releases (SDK Manager and JetPack are installed to the host…it is the L4T software which gets flashed onto the Jetson):
https://developer.nvidia.com/embedded/linux-tegra-archive
(you may need to go there, log in, and go there again since redirect doesn’t work)

Within the L4T page you will find the two mandatory command line flashing tools: The driver package, and the sample rootfs. If you were using a clone to flash from, then you could skip the sample rootfs.

My question was specifically about this new tool “NVIDIA SDK Manager” .
(I was using prior versions of Jetpack and flash.sh and everything else for years without problems.)

As I wrote above, “sudo apt install” appears to be unnecessary.
“NVIDIA SDK Manager” appears to work OK from home directory without any “sudo apt install”.
So, this was a bit of false alarm.
I wish they would have made it clear at the first place.