JetPack 4.2.1 - L4T R32.2 release for Jetson Nano, Jetson TX1/TX2, and Jetson AGX Xavier

NVIDIA is excited to have released JetPack 4.2.1 and L4T R32.2, the latest production release including new features and improvements for Jetson Nano, Jetson TX1/TX2, and Jetson AGX Xavier! See the Key Features for a list of highlights, including:

  • Headless initial system configuration via the flashing USB port or UART
  • NVIDIA Indicator Applet for nvpmodel performance power mode switching
  • The Jetson Zoo repository of popular open-source packages and DNN models
  • Support for DeepStream 4.0 and ISAAC 2019.2
  • FreeRTOS implementation for Cortex-R5 core
  • New beta features:
    • DLA support for INT8 in TensorRT
    • NVIDIA Container Runtime with Docker Integration

The NVIDIA SDK Manager can be used to install JetPack 4.2, including developer tools with support for cross-compilation.

For more information, please refer to the JetPack Release Notes and L4T Release Notes.

JetPack 4.2.1 components:

  • L4T R32.2 (K4.9)
  • Ubuntu 18.04 LTS aarch64
  • CUDA 10.0.326
  • cuDNN 7.5.0.66
  • TensorRT 5.1.6.1
  • VisionWorks 1.6
  • OpenCV 3.3.1
  • Nsight Systems 2019.4
  • Nsight Graphics 2019.2
  • SDK Manager 0.9.13

Download JetPack…https://developer.nvidia.com/embedded/jetpack
Release Notes…https://docs.nvidia.com/jetson/jetpack/release-notes/index.html
L4T Release Notes…https://developer.nvidia.com/embedded/dlc/Tegra_Linux_Driver_Package_Release_Notes_R32.2.0_GA.pdf

Hooray, DLA int8 is here.

Release notes say “The efficiency has been improved for both FP16 and INT8 modes across the platforms.” How significant is this increase?

Still looking forward to PVA support!

In the Jetson FAQ, it says “The current JetPack release does not support [external GPUs]; support will be added in a future release.” I noticed this isn’t in the release notes roadmap. Is it not a priority at the moment?

Thanks for y’all’s hard work!

Hooray! I’m really looking forward to exploring the beta support for the nvidia runtime in docker.

Hi, when I run sdkmanager-step04, the TARGET COMPONENTS -> Jetson OS -> Flash Jetson OS -> Flash Jetson AGX Xavier occurs an error: Dependency error. How do I fix it?

Hi 2427411285, can you post the error log from the ‘Terminal’ tab of SDK Manager to a new thread about your issue? Thanks.

Hi,dusty_nv. I have solved this problem. This is due to a poor network that has not yet downloaded and installed its dependencies successfully.

Hi, glad you were able to get your system flashed with SDK Manager.

Can you post the DLA issue to a new topic so our engineers can take a look? Thanks.

Hi, when I run
sudo apt install ./sdkmanager_0.9.13-4763_amd64.deb

I get this error!
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘sdkmanager’ instead of ‘./sdkmanager_0.9.13-4763_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sdkmanager : Depends: libgconf-2-4 but it is not installable
Depends: libcanberra-gtk-module but it is not installable
E: Unable to correct problems, you have held broken packages.

how do I fix it?
Thanx

Hi, are you running SDK Manager from a host PC and not the Jetson? If so, can you post your issue to a new topic so we can take a look? Thanks.

What’s the status of DMA support of “ethernet over PCIe”?

In https://devtalk.nvidia.com/default/topic/1050616/jetson-agx-xavier/the-bandwidth-of-of-virtual-ethernet-over-pcie-between-two-xaviers-is-low/3, vidyas said that “DMA support would be available in next release.”

So I want to know whether DMA is supported for “ethernet over PCIe” in this release.

Thanks.

Hi It would be useful if the embeded system was flashable without having SCREEN and KEYBOARD, and possibly over SSH. Currently, as I do not run it as a desktop it is annoying.

Hi tolysz, NVIDIA SDK Manager can be run from command line (CLI mode) from the host PC. Also the low-level L4T flashing scripts are command-line based.

For more info on SDK Manager CLI mode, see here: https://docs.nvidia.com/sdk-manager/sdkm-command-line-install/index.html

New to JetPack 4.2.1, there is headless initial system setup on the Jetson over serial port, so no display is needed to be attached to the Jetson.

Is there anybody who can answer my question?

Thanks.

Hi,

JetPack SDK 4.2.1 has synchronous DMA support, however by design its perf is limited. We are getting ~150 Mbps. We are working on Asynchronous DMA, this should give perf in Gbps. We are targeting it for next Jetpack(4.3) release in October.

Manikanta

Manikanta,

I am looking forward to the Jetpack 4.3.

Thanks.

Hello, I have just received the Xavier and installation is failing. logs in link: https://www.dropbox.com/s/y4gyyvjrmdsyatp/SDKM_logs_JetPack_4.2.1_(rev.1)_Linux_for_Jetson_AGX_Xavier_2019-08-18_19-00-31.zip?dl=0

Hi omisaleh, there is currently an outage with some of the package downloads that we are working to resolve - see this thread for reference:

https://devtalk.nvidia.com/default/topic/1061295/jetson-nano/-mtd-files-corrupted-please-help-nvidia/

Hi dusty_nv,

I have upgraded the SDK manager to version 0.9.14 (as suggested in https://devtalk.nvidia.com/default/topic/1061295/jetson-nano/-mtd-files-corrupted-please-help-nvidia/2) this morning and trying to install jetpack 4.2.1 on AGX Xavier. I am not meeting MTD corrupt file errors. But, the installation progress froze at 2.75% and download progress is staying at 0%. Its been hours and there is no progress.

Can you mention if there is anything I am missing?

Hi vusraju, does the freezing repeat itself if you cancel, exit SDK Manager and restart? Are you behind a corporate proxy or firewall that may be interfering with the connection?

Hi dusty_nv,

Yes, the freezing repeats if I exit and restart the SDK manager. Yes, my working environment is inside a corporate firewall (but usually in this environment, I am able to download any software from nvidia). I can take the device home and try the same, but just want to make sure before doing that.