JetPack 4.2.2 - L4T R32.2.1 update with DeepStream 4.0.1

JetPack 4.2.2 is the latest production release supporting Jetson Nano, Jetson TX1/TX2, and Jetson AGX Xavier.

All features are the same as JetPack 4.2.1, except:

JetPack 4.2.2 components:

  • L4T R32.2 (K4.9)
  • Ubuntu 18.04 LTS aarch64
  • CUDA 10.0.326
  • cuDNN
  • TensorRT
  • VisionWorks 1.6
  • OpenCV 3.3.1
  • Nsight Systems 2019.4
  • Nsight Graphics 2019.2
  • SDK Manager 0.9.14

Download JetPack…
SD Card Image…
Release Notes…
L4T Release Notes…

Is there a way to upgrade a existing JetPack 4.2.1 to 4.2.2 without SDK Manager? As far as I understand SDK Manager requires a Ubuntu host machine but unfortunately I have only MacOSX machines available…

Hi dkreutz, if you are using Nano, you can use the JetPack 4.2.2 SD card image, which can be flashed from any PC running Windows, Mac, or Linux following these instructions. It will reset your SD card however, so backup any code or files that you want to save first.

I bet what dkreutz meant was, why the hell we’re upgrading jetpack everytime with another pc and COMPLETE reflash the systems? it is waste of time!

We plan on moving to OTA updates through the apt server such that the packages can be upgraded as opposed to re-flashed. Regarding this particular JetPack 4.2.2 update for the Nano, it’s mainly for DeepStream 4.0.1.

1 Like

An inline simple rpm upgrade would be awesome! In the meantime I managed to use a livecd version of ubuntu and just had to add the universe repo to the list in order to get sdkmanager to function and flashed my TX2 successfully. You also have to set the password for the root and ubuntu accounts. It would be great to just use and SD card to flash the TX2 instead of the USB-B cable. Thank you though for making it so the latest image allows for the last of the files to transfer via wifi as the old build required a few more steps to enable wifi.

Is possible to upgrade the software without delete all? and install all again?

for mac users, you can use parallels +ubuntu.
it worked for us.
but i’m afraid, we’ll have to fully install updates when they are released…

I already tried this with Ubuntu 16.04 on Virtualbox, but unfortunately the virtual harddisk ran out of space during the host update.

Yes, I am not such a fan of Virtualbox.
U can use Parallels (where u can set a multitude of parameters & it is kinda lightweight IMO.)
Trust me on this , parallels really makes A HUGE difference.

it seems that I’m not the only one ;),both%20CPU%20and%203D%20performance.


Sure, but it is zero vs. 79 bucks - doesn’t justify my use-case…

Last word about that option : u have the 7 days free trial. 'should be enough to get you started.

I already had this version installed on my Nano (flashed microSD) as it was the latest version when the device arrived.
I tried to reinstall the software and it fails on installing Multimedia API (complaining about missing -lnvinfer and -lcuda).

Linking: video_decode
/usr/bin/ld: cannot find -lnvjpeg
/usr/bin/ld: cannot find -lnvosd
/usr/bin/ld: cannot find -lcuda

I get the same error again when running ./ which was left in my home folder.
However, the libraries it complains about actually exist.

This is a brand new fresh device with a single git clone in it.
I only tried reinstalling because my CUDA wasn’t working in C++. Now CUDA doesn’t work in Python either.

I flashed my brand new Xavier with the OS of this version (over usb) since it came with an older one and everything said success but now it is stuck in a loop attempting to load UI.

Is this just a dodgy version?

Typically this file wouldn’t be left over after a successful installation. Can you try re-flashing your Nano’s SD card with the JetPack 4.2.2 SD card image?

Yeah this is all I can do aside from try a different version. I have already flashed 4.2.2 on my Xavier 3 times with the same result. Edit: Fixed my issue on the Xavier – it needed the display connected during flash otherwise you can’t connect display afterwards and can’t accept licence agreement. If you power off and power on again you get the loop.

why dose this image only have 32 bits?

Hi 15618561709, JetPack uses 64-bit Linux OS (aarch64). Is that not what you are seeing on your end?

Hi Dustin,

The link on the “Jetson Nano Getting Started” page ( is still linking to 4.2.1.

Can you update it?

Thanks Elias for letting us know, will get that fixed. The correct URL to the JetPack 4.2.2 image for Nano should be: