Not able to install jetpack using sdkmanager

I have recently brought an nvidia xavier AGX. I connected it to the monitor and started it. It prompted me to complete the ubuntu installation, which I did and ubuntu 18.04 runs fine on it.
After that I tried to install jetpack using a host computer which runs ubuntu 16.04 and sdkmanager I powered the jetson in recovery mode and it was detected by the sdkmanager. Then I started installing jetpack 4.4.1 but did not select flash OS again and just tried to install other drivers. However, after downloading everything, sdkmanager asks to connect to the ip address but it cant connect to that. Probably because in the same window it talks of completing ubuntu installation and then proceed with connecting to the ip address.
But since I don’t flash OS, I don’t see any step to complete ubuntu installation appearing on xavier screen.

Next time I tried to flash OS too. But this time after “flash OS” runs for along time, I get installation error with a lot of read only errors. So neither I can flash the OS nor I can install the jetpack using sdkmanager. Please let me know if it is possible to get rid this issue or if there is a way I can manually install the jetpack from the xavier, without using the sdk manager.

I appreciate any help and will share more specific details if that is required to troubleshoot.

It should work with an Ubuntu 16.04 host, but very few people use that anymore, and so testing may have unforeseen issues. Is it possible you could update to Ubuntu 18.04?

You could flash from command line, and this would tell you a lot more. JetPack/SDK Manager is just a front end to the actual flash software. Command line has far fewer dependencies than does a GUI flash, although command line does not help pick optional packages like CUDA. If you flash on command line, then you can still run SDKM/JetPack later and just uncheck flash and uncheck adding any package you are not interested in.

Your host will have a “~/nvidia/nvidia_sdk/JetPack...version.../Linux_for_Tegra/” directory. From there, if your Xavier is in recovery mode with the USB-C cable connected to the host PC, then this will flash (I am adding some extra to save a log of the flash):
sudo ./ jetson-xavier mmcblk0p1 2>&1 | tee log_flash.txt

Then you could attach the log_flash.txt to this thread if it fails. Do be sure to have a monitor and keyboard attached to the Xavier for first boot setup in case it succeeds. This does take significant time, but there should be some output from the flash to indicate it is still working. Depending on system specs it might be up to perhaps 30 minutes to flash, although in my experience it isn’t usually nearly that long.

I tried that and that was failing too but i did not record the log. I will do it and attach it and also have a spare ubuntu 18.04 NUC, will try that and let you know.
Thanks for the help.

Hi again, Everything worked fine with the host machine running ubuntu 18.04. I didn’t have to manually installed anything.

Thank you so much for he help.