I want to install jetpack 5.12 on jetson xavier nx but I am failing

I want to install ubuntu 20.04 on jetson xavier nx. So I want to install jetpacker 5.1.2 rather than the current latest jetpack 6.0. I saw on a forum here that you need $sdkmanager –archived-versions to install older jetpacks. However, when I run sdkmanager with this option, the selectable sdk version does not appear. tell me what’s wrong.

You need a Ubuntu 18.04/20.04 host PC to install JetPack 5 with SDK Manager.
Or please directly download the BSP and flash with command line.

I followed your advice and changed the host to ubuntu 20.04. But the problem still remains. What can I do?

Then please do this.

Before the release of jetpack 6.0, I installed it normally using sdkmanager. If so, I think it is a problem dependent on sdkmanager 2.0, which includes jetpack 6.0. How do I get sdkmanager that includes the previous version, i.e. jetpack 5.x?

Maybe you need 1.9.3:

thank you. However, if you install and run sdkmanager 1.8.4, there is a problem where you cannot log in. Is there a solution?

If there is no solution, I would like to follow your advice and try it from the command line, but my xavier nx board is a Chinese domestic version, so it uses internal flash (16GB) rather than an SD card. Additionally, NVME 128GB is installed. However, the command line quick start guide says “Ensure that your Jetson Xavier NX Developer Kit is powered off, and a 64GB or larger microSD card is inserted in the SD card slot.” There is something like this. Is it okay to ignore this and flash it? Or is there a way to download it directly to NVME?

If it’s an eMMC module, then you are supposed to select the second option in the first screen shot you posted earlier.

I’m sorry, but what does the second option mean?

I mean this one.
Anyway, if you cannot get it done, please just flash with command lines.

I tried the second option, but the problem did not improve. So I’m going to try it from the command line. The flash capacity of my board is 16GB. However, the quick start page says to use an SD CARD of 64GB or larger. Is there any problem if I proceed?

Do this to flash the NVMe, please.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_l4t_t194_qspi_p3668.xml" \
  --showlogs --network usb0 jetson-xavier-nx-devkit-emmc internal

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.