JetPack 5.1.0 required

Hi, I currently am running JetPack 5.1.3 on my Xavier NX. I want to downgrade to JP 5.1.0 with the sdkmanager for ubuntu 20.03. I am not able to find the specific version. How do i go about this issue, i also need a specific l4t version. thanks.

Please give more detail on this.
I don’t really know what you mean.

Hi,I am fairly new to robotics and i am working on a project for a tracker drone. I have a jetson Xavier NX module mounted on a third party carrier board. I have flashed JP 5.1.3. Now I have obtained an embedded camera which I want to use ,and the documentation for it states that it is compatible only for jetpack 5.1.0 with L4T 35.2.1. I am looking for this version on my sdkmanager that I’m running on my ubuntu host machine 20.04. How do i flash the required JP . Thanks for taking the time

I mean what’s your problem with I am not able to find the specific version.?
You cannot find it on SDKM? Any screenshots?

yes i am not able to find the jetpack i need
I will share the screenshots in a moment

You might consider just running “sdkmanager --archived-versions”. This makes other releases available. JetPack/SDK Manager is just a front end for what actually flashes. What you’re really asking for is the L4T release installed by JetPack 5.1. You can see the current L4T release with “head -n 1 /etc/nv_tegra_release”.

SDKM is the “smart” network layer on top of JetPack. You can find specific releases of L4T and JetPack/SDKM here:

Beware though that a Jetson module on a third party carrier often requires different firmware (the device tree). You should consult the manufacturer’s information about flash before you use the dev kit software. Quite often the third party will say to use the dev kit software after adding a patch; sometimes the manufacturer will provide their own rebranded software (which is basically the NVIDIA flash setup with a new device tree). On some occasions the manufacturer will follow the electrical layout of the dev kit carrier board and state that you can just use the NVIDIA software directly.

1 Like

Thanks for the clarification. However, I am not able to obtain the version i require by running the “sdkmanager --archived-versions”. I am now trying to run sdkmanager using a customised configuration by following this page: The Extra Configuration File — SDK Manager 2.1.0 documentation. I don’t think it will work , but I will give it a shot anyways.
I am currently using the NX module on this carrier board: reComputer J202 Carrier Board for Jetson Xavier NX with compact function design and same size of NVIDIA® Jetson Xavier NX™ carrier board - Seeed Studio
Thanks again for helping out

Then what versions can you see in the SDKM menu?
You still did not give screenshots?



Hi dave, sorry I wasn’t able to login yesterday. Here are the available versions when i run sdkmanager --archived-versions

You don’t need --archived-versions at all.

Okay, I tried the normal one, and it shows the version i want. I proceeded to step 3 and it was progressing for almost 20-25 minutes ,after that it abruptly showed dependency errors for all the installations.
I am restarting the whole process by formatting my Ubuntu host. I will revert back if the same error persists. Thanks for your time