Trying to install jetpack on ubuntu 22.04

I’m trying to flash jetson tx2. I installed sdkmanager on my ubuntu 22.04 machine (not VM). However, the target operating system says "No available releases for host OS: ubuntu2204.
I even tried manually installing jetpack from terminal by running “sudo apt install nvidia-jetpack”. But it says “Unable to locate package nvidia-jetpack”.

Please let me know how can I install jetpack os on ubuntu 22.04.

If it is not possible, please let me know if there are any other ways to flash/reset the Jetson TX2.


Please have a host PC with Ubuntu 18.04 to install SDK manager to flash TX2 via JetPack.
The Ubuntu 20.04 and 22.04 is not supported for TX2.

Note: JetPack/SDK Manager is just a GUI frontend to the actual flash software. JetPack/SDKM does not care that you are using Ubuntu 22.04, but the underlying software being flashed does. This is why for the releases available to a TX2 you need an Ubuntu 18.04 host PC.

I understand. But can I use a Ubuntu 18.04 VM on an Ubuntu 22.04 machine to do the task? Will sdkmanager and jetpack flashing procedure work on VM?

This is not supported. The reason is that NVIDIA flash software has no control over the configuration of the VM, and many VM setups fail to hold onto the USB if it disconnects and reconnects (and during a flash this is the expected behavior of the recovery mode Jetson). Each VM brand setup is also different. If you can set up USB correctly, then it will work, but it isn’t directly supported (sometimes you can still ask on these forums though and someone who has done this before could answer a VM question). If you do use a VM, be sure you have enough disk space (it takes a lot), plus make sure the filesystem type is ext4.

1 Like

No. Won’t work. Tried that. The USB passthrough usually is not good enough as there are multiple disconnections and reconnects. You really absolutely MUST use a bare metal machine using the correct Ubuntu version in order to get this working reliably. However, this may also be a smaller or older machine. Something like an Intel J4125 Atom should be enough. Must be amd64/x86-64 architecture though - no Apple M1, Raspberry Pi and no 32 bit PC platforms etc.


Personally I’ve been using Ubuntu 18.04 VM on Windows 10/11 and the USB reconnections have been working just fine

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.