JetPack 4.4 Developer Preview - L4T R32.4.2 released

We are pleased to announce JetPack 4.4 Developer Preview supporting Jetson AGX Xavier series, Jetson Xavier NX, Jetson TX2 series, Jetson TX1, and Jetson Nano. (JetPack 4.3 remains the latest production release.)

JetPack 4.4 key features include support for Jetson Xavier NX module, new versions of CUDA, TensorRT and cuDNN, and support for the upcoming DeepStream 5.0 Developer Preview.

Please refer to the JetPack Release Notes and L4T Release Notes for additional info.

JetPack 4.4 Highlights:

  • Support for the new Jetson Xavier NX module
  • Support for CUDA 10.2, and developer preview of TensorRT 7.1.0 and cuDNN 8.0.0
  • Support for Vulkan 1.2 and VPI 0.2.0 (Developer Preview)
  • Support for upgrading JetPack and L4T using Debian package management tool
  • Support for Generic Timestamping Engine (GTE) for Jetson AGX Xavier and Jetson Xavier NX
  • Support for Dynamic Frequency Scaling (DFS) for Video Image Compositor (VIC) using actmon
  • SE (Security Engine) samples to demonstrate hardware backed authentication and encryption capabilities of Jetson TX2 series, Jetson AGX Xavier and Jetson Xavier NX modules.
  • Utility to fuse multiple Jetson modules simultaneously
  • Option to specify APP partition size on the microSD card during initial configuration at first boot of Jetson Nano Developer Kit

JetPack 4.4 components:

  • L4T R32.4.2
  • CUDA 10.2
  • cuDNN 8.0.0 (Developer Preview)
  • TensorRT 7.1.0 (Developer Preview)
  • VisionWorks 1.6
  • OpenCV 4.1
  • Vulkan 1.2
  • VPI 0.2.0 (Developer Preview)
  • Nsight Systems 2020.2
  • Nsight Graphics 2020.1
  • Nsight Compute 2019.3

Existing installations of JetPack 4.3 can be upgraded in-place to JetPack 4.4 Developer Preview without re-flashing the device. For more information about upgrading JetPack via the Debian package management tool, please refer to the JetPack documentation here.

Download JetPack…https://developer.nvidia.com/embedded/jetpack

JetPack Release Notes…https://docs.nvidia.com/jetson/jetpack/release-notes/index.html

L4T Release Notes…https://developer.nvidia.com/jetson-linux-driver-package-release-notes-r3242-dp

Just wanted to report. I sucessfully OTA updated using the apt repos. No problems encountered. Thanks for the new stuff!

Updating the JetPack without flashing the Jetson is simply amazing ! Thx !

installation failed on Xavier AGX:

Unhandled error when running sudo apt-get -y install cuda-toolkit-10-2

missing cuda-samples-10-2
missing libxmu-dev

Just a feedback about upgrading a Xavier OTA from R32.3.1 to R32.4.2 a few days ago :

I did that upgrade according to this doc (To upgrade to new minor release).

I had almost 4GB available in my eMMC rootfs. The upgrade process downloaded about 2.5 GB, but no check was made for available disk space.
So one of the l4t components failed to install, I tried to reboot and it asked me to confirm… I did.
Upon reboot, it was failing to start the Xserver.
I connected as explained here in order to free more space (had to copy all my opencv versions to an unreliable disk).

Then I faced strange problems with Argus. I also noticed that apt cache was full of both old and new versions.

So here are the various commands I have launched and cleared my case (not sure all are required, try at your own risks):

sudo apt update
sudo apt dist-upgrade
sudo dpkg --configure -a
sudo apt dist-upgrade
sudo apt --fix-broken install
sudo apt dist-upgrade
sudo apt auto remove
sudo reboot
...
sudo apt-get clean

Hope it helps.

I’m not seeing DeepStream available in the apt feed for r32.4. Is this going to be published soon?

Additionally, are there any plans to make the public apt key available? Most other vendors supply the key and urls for their repos publicly. For example: Docker, .NET Core.

1 Like

I don’t get it. I could have sworn it’s in their repos and now it’s gone. It’s like the desire is not to use it. I get waiting until 5.0 release for 5.0 but 4.0 is gone as well.

And yeah. A keyserver would be nice. I’ve been asking for this. Google even has a repo and keyserver that works on Tegra. As for Nvidia’s key you can get it in the BSP tarball, rename it, and put it in the right location like this image does:

https://hub.docker.com/repository/docker/mdegans/l4t-base

Hi, I’ve met the same problem with you, have you solved this problem?

I faced some issues with apt packages which could not be found on the Xavier module.

I think my problem was that I did an headless installation, and did not configure the network connection properly.

My problem was that I was unable to install libxmu-dev and even a trivial package such as xfce4. I tried to run apt update but this did not work properly.

My hack was this procedure:

  • comment all package sources in /etc/sources.list
  • run apt update
  • uncomment package sources commented before
  • run apt update again

This sort of triggered a refresh of the packages, and now I can install libxmu-dev.

Can anyone explain a bit more why this would work, what should be done differently?