NVIDIA SDK Manager fails to load to Xavier AGX


I have followed the JetPack installer guidelines to install.
I get a message saying there is not enough space to download the full installation.
I thought I had about 9GB of space, and the download is saying it only needs 6 GB.

I selected to download now and install later, which worked.
Clearly, the SDK Manager thinks I do not have enough space on the Xavier.
It is connected via USB and I pressed the Forced Recovery and Power buttons.

I have yet to see any kind of indication on my screen connected via HDMI that the Xavier is alive even though the power light is lit.

I don’t have the Xavier connected to my local network via ethernet, but that doesn’t seem to be necessary to download via USB.
Am I missing something obvious?


Hi rsheffield,

The system requires up to 10GB of available disk space during setup:
Download folder: this is download JetPack deb files.
Target HW image folder: this is download JetPack image files.
Please check your host Ubuntu machine have enough disk space for this.
Reminder, the SDK Manager is run on your host Ubuntu machine, not Xavier.

Thanks for the quick reply.

My Ubuntu host system now has an NVIDIA folder containing 6.2GB of info, a sdkmanager_1.0.0-5517_amd64.deb file of 63.7MB, and has 3.7GB of “free” space in the Downloads folder. This “should” have been enough space to allow for the download, then proceed to the install of the image on the Xavier. I only have a couple of other files in the Download folder which represent about 650MB of data.



Hi rsheffield,

You can’t change the “Target HW image folder” link, but you can change the “Download folder” link.
Please show your host Ubuntu machine disk space with below command:
$ df


I found 30 GB of data I could move to another partition.
Download and install began, but failed to finish with the following error detail.


Says I have held broken packages.

How do I correct this?

This keeps all the SDK packages from installing.


After more examination, I see that the VisionWorks 1.6 on Host failed to load in the Computer Vision Components.

I’ve tried to download again, but end up with the same error.
How can I get past this problem?


Hi rsheffield,

Please attached logs on here.
$ tar cvf sdklogs.tar ~/.nvsdkm

What is your host ubuntu machine version? 16.04 or 18.04?

I sent a compressed (zip) file of the nvsdkm file containing the logs attached as a reply to your email notice.
Please let me know if that got to you or if I need to use a more direct email address.

My host machine is running Ubuntu 18.04.3
nvsdkm.zip (781 KB)

Note that if you hover your mouse over the quote icon in the upper right of one of your existing posts, then other icons show up. The paper clip icon is for attaching files.

Thanks, it is not intuitively obvious hat you can attach a file after the reply is made.
Has been saying “scanning … please wait” for a very long time.
Not altogether sure it is working.

Hi rsheffield,

Please run below command on your host Ubuntu machine:

sudo apt-get update
sudo apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev
sudo apt-get install gstreamer1.0-plugins-bad-videoparsers

Then run sdkmanager again to install Visionworks on your host machine.

When I try to do step 2, I get the same error as when previously running sdkmanager.
It states that have held broken packages.

I’ve attached a screen shot of the complete error message.


Will this enable the attachment?

Hi rsheffield,

I think you are missing some package on your host machine.

Please try below:
$ sudo apt-get update --fix-missing
$ sudo apt-get update
Then install gstreamer packages.
Please check your host machine packages are installed and update success, then run the sdkmanager.

I did the --fix-missing, apt-get update and still get the same error message that I have held broken package.
See attached.
The only thing I see that is failing on the update is that i386 packages are skipped.
Could that somehow be the problem?


enable attachment



Hi rsheffield,

Please check your host Ubuntu machine architecture:
$ dpkg --print-architecture

If you have others architecture, please remove them and only keep “amd64”.
Then do the #14 again.

I checked, and only have amd64 architecture.

I’m a bit confused by the request to do #14 again.
What does that refer to?

Is it possible for you to simply post a download image on a ftp or dropbox site?

My goal is to hook up a 6 camera MIPI CSI board from Leopard Imaging with cameras as soon as possible to evaluate the quality of the video produced.
The Leopard Imaging site says their driver for the Xavier is in JetPack 4.2.2.
I’m assuming that this driver will also be in JetPack 4.3.
Please advise if I’m wrong.

I’ve deleted and installed the entire NVIDIA folder created by sdkmanager twice on my host machine.
Both times I have encountered the problem with a held broken package after trying to install on the target machine.
I really need to move past this problem to make progress.