Hibernation broken with 384.59+

I already had problems with hibernation with version 375.66 (https://bugzilla.kernel.org/show_bug.cgi?id=188281), but at least hibernation worked after manual power-off. Now, with 384.59, I just get a black screen but no hibernation image is written to disk. (I had had high hopes in this driver version as it said in the release notes that there was some fix for some kind of hibernation issue, but alas, it has gotten worse rather than better.)

I tried it with kernels 4.4.74, and 4.12.0-rc6, both with the same result, also I tried my distribution’s package for 4.4.74 and manually installing the driver – same result. After downgrading the driver, I can hibernate again (with manual power-off after the disk light goes out).

I’ll try to attach my nvidia-bug-report.log.gz once I figure out how to do that.

Log attached
nvidia-bug-report.log.gz (82.2 KB)

Same problem with 384.90.
nvidia-bug-report.log.gz (88.5 KB)

I wonder: does any nvidia developer ever read this forum or is there some real bugtracker for the nvidia linux drivers? This forum is all I could find regarding bug reports, but there seems to be no response at all. I’d be glad providing more information to help fixing that driver’s hibernation regression.