How can I remove the jetson nano's nvidia logo from uboot - err... I mean cboot (Edit)?

Hello, I have a jetson nano 4GB developer kit, and I have been trying for around 5 years to figure out the proper
way to remove the boot logo. I have tried creating a custom image - which maybe needs a video tutorial as some of us learn that way better, and creating a custom bmp.blob for that image, and it worked the first boot. But, the next boot it
was back to the nvidia logo. I also tried editing config files, but I know that just flat out doesn’t work.
Really, I want to disable it, but in that situation, I just made the whole image black, but it only worked the first boot.
If you can tell me the full solution and detail it, it would help tremendously in my understanding. Thank you! :)

Hi,

I would like to know what you’ve tried so far. Also, the logo is from cboot so dump the uart log will help tell why it is black.

Hey - about the logo being black - That was intentional. I don’t actually want the logo to be displayed.
I’ve tried the following:

  • I have used the non-nv tool to create a bmp blob, and using the pythops linux 4 tegra bsp I have created the image.
    This only worked on first boot. I believe I also tried a few times prior with this method and resize2fs didn’t work properly.

  • I have modified the /etc/X11/xorg.conf file to add “Option (NoLogo)”

  • I have removed the bmp partition from a file mentioned here as well as the blob: Where is the nano's boot screen pic located? - #5 by duanlinlin

  • I have changed a few images mentioned in other forum posts, but I believe those were for after x is started.

  • I’ve tried using Plymouth to change it - I don’t exactly remember how.

The only thing that yielded some success was the custom image.
I’m very confused by the linux 4 tegra documentation to be honest, because it kinda puts you
right in the middle of everything and there’s a lot of cross referencing it seems.

:)

The story is if you are using some old jetpack release, then it is reasonable that you use some non-NV tool because the BMP generation tool is not release at that time.

However, if you are using jetpack4.5.1, then as my comment here:

You can directly refer to the readme file in the driver package.

Also, we don’t support boot logo from uboot. The boot logo is in cboot. Thus, plymouth has nothing to do with it because Plymouth is running after kernel is up. Also, xorg.conf has nothing to do either because it is after kernel too.

What is the exact goal here? Modifying the logo to something else? or just disabling the logo?

If you just want to disable logo, removing bmp.blob or removing the whole partition should be fine. Again, debug such case requires the log from uart. Otherwise we are just watching the screen over and over again, don’t know what happens.

Oh ok, I see. I read somewhere that nvidia jetson nano uses uboot.
I suppose I mean cboot then. There’s a lot of misinformation going around about the jetson nano it seems.
I just want to disable it.
I actually did this a long time ago, so I will have to remake the image to get the uart log.

Is this the proper link for the L4T? I also heard L4T has jetpack built in now?
https://developer.nvidia.com/embedded/l4t/r32_release_v5.1/r32_release_v5.1/t210/jetson-210_linux_r32.5.1_aarch64.tbz2

Also, I believe I use sudo to extract this, correct?
OR, was that for the root filesystem?

Linux_for_Tegra is just the driver package which contains the tool for flash and doing other configuration. It does not contain the sdk as cuda, cudnn, tensorRT…etc.

It could be required by either:

  1. SDKManager. It is a auto tool that ask you to click some GUI and then help you flash the board and install the sdk.
    SDKM will install L4T package to the default path (~/nvidia) on your x64 host.
  1. The link you pasted. That is the tarball for driver package. However, it does not contain the root filesystem. Which means you have to download the rootfs from below page. And you have to manually set them up

For me, I would prefer the easy way, let sdkm prepare all the items and I just use the flash tool to flash the board.

I know that many jetson nano users don’t even know the existence of sdkmanager or such flash tool because relying on the sdcard image. For such case, reading the quick start guide from below page would help get familiar with those flash tools.

It may not be “misinformation”, but just lacking of precision. For example, what is the definition of splash screen? Some users may enable logo from uboot by themselves and share it on forum and thus some users may think the default logo is from uboot. Or maybe others enable plymouth and once again causing some others think the logo is from plymouth.

We mentioned in developer guide as below.

Huh, I have used these tools here and there.
I’m curious, is there an option in the SDK Manager to change or disable the cboot logo?
Good points!

No, what sdkmanager will do is just install default jetpack to your devices.

Removing or configuring something from default jetpack is not what sdkm supports. It is just an entry level tool.

Ok, so I should probably use the link I posted then, right?
Some form of the driver package would be necessary to change or disable the cboot logo?

I guess you didn’t get my point. I suggest you not to use that link because you may come back again with lots more questions for setting package up, which is not related to boot logo issue at all.

You just try sdkmanager, let it download the package but no flash, which will provide you a well-prepared pakcage to your host in path (~/nvidia). Then, go to check the readme file for bmp tool.

If you try the tarball from your link, you will need to spend time preparing that package by yourself, which may hit problems, and after a while finally go to check the readme file for bmp tool.

Of course it is just possible but not definitive. It depends on you for which method you want to adopt.

Ohhh! I see! Thank you so much! :)

I’ll see if that’ll do it. Maybe I won’t have the issue at all then.

Just do not connect the micro usb cable when running sdkm and it will not flash your board directly. But it will install the pre-built package to your host.

Also, Jetson OS and Jetson SDK can be installed separately. If you want to save time to check logo issue first, just select Jeston OS in below page on sdkm so that sdk will not be installed.

1 Like

That is also fine. Learning some new stuff is also good. You may need the help of quick start guide as my previous comment.

Alright, well this topic is getting kinda long.
I’ll try it out. It seems like this will be a more stable image this way.
I’ll probably start a new topic if it doesn’t work. Thank you!

1 Like

Yep! That was the solution!
Thank you so, so, so, so much!
I really appreciate it!
Now the logo is persistent! :)
Perfect!