How do I turn EGL Display off?

I want to login through SSH terminal,then run deepstream-app. I ask how do I turn EGL Display off?

Hi,
Please check sink group:
https://docs.nvidia.com/metropolis/deepstream/4.0/dev-guide/index.html#page/DeepStream_Development_Guide%2Fdeepstream_app_config.3.2.html%23wwpID0ENHA
You can disable EGL based windowed sink (nveglglessink)

I’ve disable EGL based windowed sink in the config file, Program debug “nvbufsurftransform: Could not get EGL display connection”.

My config message:
[sink0]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File
type=1
sync=1
source-id=0
gpu-id=0

You shall still need to set ‘export DISPLAY=:1(or 0)’

I login System Through Display Screen, turn off EGL in the configuration file and export DISPLAY=:1,then run deepstream-app in SSH terminal success.
If I doesn’t login System through Display Screen,turn off EGL in the configuration file and export DISPLAY=:1, run deepstream-app in SSH terminal fail, error log is
"
No EGL Display
nvbufsurftransform: Could not get EGL display connection
"

Hi,
A user has shared a solution:
https://devtalk.nvidia.com/default/topic/1063434/deepstream-sdk/-nano-nvbufsurftransform-could-not-get-egl-display-connection/post/5387641/#5387641
Please give it a try.

I try this user’s solution,
1)export DISPLAY=:1 or export DISPLAY=:0;
2)Disable X11。
Recompile deepstream-app,still “No EGL Display”.I login System Through Display Screen,then run deepstream-app in SSH terminal success.

Hi,
Please check with the user. We hope users can share with each other.

unset display in terminal shown below.

$ unset DISPLAY

Then run deepstream-app. It will solve the below errors.

No EGL Display
nvbufsurftransform: Could not get EGL display connection

Nice! Thanks for sharing!