How Nano Remote by internet?

Hello,

I need learn how , can I remote of jetson nano by Internet? do you any tutorial?

thanks
Leo

Hi Leo, if you enable port forwarding on your router for port 22, you should be able to connect over SSH. You may also need to create or disable firewall rules on your router if it has those enabled. In general, connecting to your Nano remotely over SSH should not be very different from other Linux platforms. So if you are able to configure your router/gateway to accept incoming remote connections to a PC, it should also work with Jetson.

Here are some detailed instructions, including how to configure public key authentication.

As stated in that post, I would recommend not allowing password authentication if you are connecting ssh to the bare internet. By default there is no limit on the rate or number of times you can retry credentials, and you’re likely to get tries from all sorts of fun places if you check your logs.

Hi good day,
I need some program similar to teamviewer, to connect. in which with username and password you can remote without configuring router.

I have tried with the armhf version of teamviewer but I have not managed to walk, it closes spontaneously no matter how much I set up tvw_main for aarch64 and put the resolution.

From now I appreciate your comment

armhf is a different (32-bit) architecture. This needs 64-bit (arm64/aarch64).

If the Nano initiates the connection, then no router adjustment is needed. If some outside world connection needs to reach the Nano by going through a router, then the router must be told to do this, there is no other way (if the router is in bridging mode, then this would work, but then it isn’t a router anymore, it is a bridge…sometimes routers can be configured to work either way, but it is up to the ISP to support this or not).

I have no experience setting up teamviewer, but the aarch64 version would be correct if all other requirements are met.

Minor note on bridging. If you bridge your Nano to the bare internet, you will probably want to “sudo apt install ufw && sudo ufw enable” to turn on a firewall. Generally port forwarding is a better idea since you’re only exposing the needed port and your gateway (hopefully) handles all the firewall business.

As dusty_nv mentions, setup should be no different than regular Ubuntu 18.04. You might have a look at these articles:

https://www.techrepublic.com/article/how-to-install-a-vnc-server-on-linux/
(you can use another VNC server instead, if performance is poor)
https://www.techrepublic.com/article/how-to-connect-to-vnc-using-ssh/

All you need do is forward TCP port 22 at your gateway (router) for this to work. This will differ from gateway to gateway. If you send a screenshot, I can probably help if you’re stuck.

Hello, I understand what they tell me and it is good, but this is not possible when you pass the internet through a smarphone

Depending on your carrier it might be impossible. Also, you’ll probably use a ton of data. Depending on your carrier that could be bad. With a dynamic dns client on the Nano you might be able to do text based ssh and maybe some data transfers depending on how good your data plan is.

If you find a dynamic dns client (which will differ per service), you’ll want one that allows you to build from source. I know noip will, but i can’t say for others. Note that it’s not easy to set this up, nor is it guaranteed to work.

thanks for your reply

That’s why I try to :

https://devtalk.nvidia.com/default/topic/1056851/jetson-nano/remote-desktop-for-nano-/

but I have the same error:

Init…
CheckCPU: aarch64
Checking setup…
Launching Teamviewer…
Launching Teamviewer GUI…
Aborted (core dumped)

although in an power on it went well

Unfortunately I have never used Teamviewer, so I don’t know anything about that error.

If you did this, then that would account for the core dump:

sudo dpkg --add-architecture armhf

(I saw this in the URL you pointed out)

The Nano architecture is ARMv8-a, which is 64-bit. A compatibility mode 32-bit is just ARMv8 (no “-a”). This happens to be a superset of armhf, and can run armhf if and only if all of the other support has been added, e.g., the linker, all system libraries, so on. In that case it would be attempting to run teamviewer in 32-bit mode, and failing to find matching libraries and linking capability would indeed force a core dump since they do not exist. Had this worked, then the performance would have been absolutely terrible, and may have had some compatibility issues for other reasons as well.

We use www.remote.it . It has been working great for over a year for us. It is free for non-commercial use.

If you just need a VPN, Wireguard works with the default Ubuntu 18.04 installation instructions:
https://www.linode.com/docs/networking/vpn/set-up-wireguard-vpn-on-ubuntu/

DKMS works as expected to build the module for the Tegra kernel.

wireguard:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.140-tegra/updates/dkms/

Other vpn providers (eg. OpenVPN) probably also work but I haven’t tested them.

@mdegans Can you share how you installed Wireguard? Following the steps in the linode tutorial leads me to the following, and seems like it is unable to work with the tegra linux headers:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  wireguard-dkms wireguard-tools
The following NEW packages will be installed:
  wireguard wireguard-dkms wireguard-tools
0 upgraded, 3 newly installed, 0 to remove and 263 not upgraded.
Need to get 342 kB of archives.
After this operation, 2,032 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 wireguard-dkms all 1.0.20200611-1ubuntu1~18.04.1 [250 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 wireguard-tools arm64 1.0.20200513-1~18.04.2 [88.5 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 wireguard all 1.0.20200513-1~18.04.2 [3,268 B]
Fetched 342 kB in 1s (284 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package wireguard-dkms.
(Reading database ... 137658 files and directories currently installed.)
Preparing to unpack .../wireguard-dkms_1.0.20200611-1ubuntu1~18.04.1_all.deb ...
Unpacking wireguard-dkms (1.0.20200611-1ubuntu1~18.04.1) ...
Selecting previously unselected package wireguard-tools.
Preparing to unpack .../wireguard-tools_1.0.20200513-1~18.04.2_arm64.deb ...
Unpacking wireguard-tools (1.0.20200513-1~18.04.2) ...
Selecting previously unselected package wireguard.
Preparing to unpack .../wireguard_1.0.20200513-1~18.04.2_all.deb ...
Unpacking wireguard (1.0.20200513-1~18.04.2) ...
Setting up wireguard-dkms (1.0.20200611-1ubuntu1~18.04.1) ...
Loading new wireguard-1.0.20200611 DKMS files...
It is likely that 4.9.140-tegra belongs to a chroot's host
Building for 4.9.140-tegra
Building initial module for 4.9.140-tegra
ERROR (dkms apport): kernel package linux-headers-4.9.140-tegra is not supported
Error! Bad return status for module build on kernel: 4.9.140-tegra (aarch64)
Consult /var/lib/dkms/wireguard/1.0.20200611/build/make.log for more information.
Setting up wireguard-tools (1.0.20200513-1~18.04.2) ...
wg-quick.target is a disabled or a static unit not running, not starting it.
Setting up wireguard (1.0.20200513-1~18.04.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...```