How to configure VNC w/o monitor for Jetson

Dear NV team,
I used VNC for monitoring Jetson AGX Orin 32GB devkit desktop, once Jetson monitor is attached, it worked fine. Once no monitor, I referred to, but failed to connect (from Windows or Ubuntu PC). Attached is the VNC debug messages trying to connect using gvncviewer from Ubuntu PC. If VNC cannot do it, any other approach to do it? Thanks.

vnc debug.txt (5.2 KB)

Hi andrew.li611216,

What’s your Jetpack version in use?

From your log, it seems your issue is about “Connection refused” rather than monitor connected or not.
Please check if the connection authentication is correct.
Or check if your board is in suspend to cause this issue.

You can also use VNCViewer instead of gvncviewer.

Hi KevenFFF,
I tried JetPack 5.1.2, 5.1.3 and 6.0, using gvncviewer and vncviewer from remote Ubuntu PC as well as using tightVNC and realVNC from remote Windows PC, they all could not be connected w/o a Jetson monitor. Once monitor is attached, VNC connection will be ok.
Now I suspect whether it was caused by the “dummy display adapter”. Is it mandatory to use a dummy display adapter? Currently I have not used it. Thanks.

What do you mean about “dummy display adapter”? Is that a physical device connected on your board?

From the result of our verification, you don’t need to add dummy display configuration if you connect a monitor for Jetson.
Actually, VNC connection should still work w/o monitor connected.
The display from VNCViewer will freeze if you don’t add dummy display configuration when you disconnect the monior.
As a result, you should add dummy display configuration when the monitor is disconnected.

In short…
With monitor connected → use original xorg.conf (xorg.conf.backup)
W/o monitor connected → use xorg.conf with dummy display configuration (xorg.conf.dummy)

Thanks KevinFFF.

Hi KevinFFF,
Yes, “dummy display adapter” is a physical device attached with Jetson to replace the monitor.

If you connect a “dummy display adapter”, then it should be similar as you connect a monitor.
Please just use the original xorg.conf.

Or you can remove this adapter, and just use the dummy display configuration.

Thanks for the clarification. I thought dummy display configuration didn’t work so considering to use a displayport adapter.

Now I flashed latest JetPack 6.0 to my Jetson AGX Orin and did the display dummy configuration as your suggested, VNC connection works now.

  1. using TightVNC from Windows, looks perfect. 2) using vncviewer from Ubuntu, it is quite slow but does work.

Thanks KevinFFF.

Btw, with Jetpack 6.0 you can mstsc (default remote desktop) to remotely connect from Windows machines to Jetson.

Hi sukesh3,
it looks authentication is a problem, will do more tests, thanks.

BTW, from Ubuntu, if installing tigervnc-viewer, the connection will be smooth.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.