Jetson Orin No monitor, VNC only splash screen until monitor connected

I want to use vino-server for VNC with no monitor connected on Jetson Orin Developer Kit - Jetpack 5.0.1 DP. When I connect with VNC Viewer, only the splash screen is shown until I plug the DisplayPort until the monitor, then desktop then shows and is interactive but when I disconnect the DisplayPort, the vnc becomes unresponsive (mouse moves but nothing seems to be interacting).

I tried configuring the vnc/screen-sharing according to this. I tried using both ways (one at a time) for step 1 (autostart and symlink).

I also tried turning on Screen Sharing in Gnome setting page.

I also tried editing the /etc/X11/xorg.conf to add in a Screen section according to README-vnc.txt. Which didn’t work also.
I then tried adding in Monitor section into /etc/X11/xorg.conf. Also still didn’t work.
I also tried installing xserver-xorg-video-dummy then adding a ‘dummy’ Device and change the links in Screen section. Still didn’t work.

On previous Jetsons like Jetson AGX Xavier Dev Kit and Jetson Nano Dev Kit, I was able to use VNC without monitor by just following the instruction on the VNC set up page then adding Screen section to /etc/X11/xorg.conf according to the README-vnc.txt.

Odd note:
I also tried reflashing and reconfiguring the Jetson again. It oddly works only on first installation of xserver-xorg-video-dummy, the desktop became interactive, but after a reboot, it came back to ‘stuck’ at splash screen (and other symptoms as described above). I tried both removing and purging the xserver-xorg-video-dummy package and reinstall but can’t make it work again until first installation of xserver-xorg-video-dummy after another reflash.

Please share the steps so that we can replicate the issue and do investigation. 5.0.1 DP is developer preview so it is possible certain functions do not work. We would need to check further.


  1. Reflash Jetpack 5.0.1 DP using SDKManager (follow instruction inside sdkmanager).
  2. Run commands according to this.
cd /usr/lib/systemd/user/
sudo ln -s ../vino-server.service ./.
gsettings set org.gnome.Vino prompt-enabled false
gsettings set org.gnome.Vino require-encryption false 
gsettings set org.gnome.Vino authentication-methods "['vnc']"
gsettings set org.gnome.Vino vnc-password $(echo -n 'password'|base64)
  1. Edit /etc/X11/xorg.conf. Add the following to the end of the file (according to README-vnc.txt)
Section "Screen"
   Identifier    "Default Screen"
   Monitor       "Configured Monitor"
   Device        "Tegra0"
   SubSection "Display"
       Depth    24
       Virtual 1280 800 # Modify the resolution by editing these values
  1. Sudo reboot now

  2. Connect VNC viewer to Jetson Orin (splashscreen shown)

Hi ped02,

Besides follow setup VNC server introduction, please also enable below:
Settings -> Sharing -> Screen Sharing -> set 'Active'

You may try this. It works fine for me.
1、sudo apt-get install xserver-xorg-video-dummy -y
2、Change /etc/X11/xorg.conf as follows:
Section “Device”
Identifier “Configured Video Device”
Driver “dummy”

Section “Monitor”
Identifier “Configured Monitor”
HorizSync 31.5-48.5
VertRefresh 50-70

Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
DefaultDepth 24
SubSection “Display”
Depth 24
Modes “1280x720”

3.Download URDC and install then push res\aarch64\urdcd to Orin and run it. URDC is another remote display and control tool for Jetson device.It is simple and easy to use and with CUDA acceleration.
URDC(B2082).exe (6.0 MB)

1 Like

Here is the video tutorial for using URDC on Orin

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.