VNC without display

Hello,

We’re trying to setup orin desktop without display. Note that we don’t have physical access to the device and it’s not plugged into a screen. Our end goal is to be able to access the desktop via vnc, using screen sharing or x11vnc.

In our past experience with jetson devices, creating a virtual screen is enough, but this don’t seem to be the case with orin.

NVIDIA docs and other forum posts points to this page – Setting Up VNC | NVIDIA Developer

This setup is broken,. calling gsettings throws dbus errors because there’s no screen attached. To circunvment this we tried editing dbus settings using x11 forward pass, which was extremely annoying to do, but got vino-server working, it does listen on 5900 and connects, however all connections drop since, again, there’s no display.

Finally we also tried x11vnc, which does connect and show the splash screen, which is not interactive at all. It seems to be just a dummy, since running glxgears seem to work but renders nothing.

I’ve attached Xorg log and xorg.conf, in syslog I see some activity when trying to connect, but no errors:

Sep 19 19:40:43 ubuntu vino-server[2419]: 19/09/2022 07:40:43 PM [IPv4] Got connection from client 10.242.0.75
Sep 19 19:40:43 ubuntu vino-server[2419]: 19/09/2022 07:40:43 PM   other clients:
Sep 19 19:40:44 ubuntu vino-server[2419]: 19/09/2022 07:40:44 PM Client Protocol Version 3.7
Sep 19 19:40:44 ubuntu vino-server[2419]: 19/09/2022 07:40:44 PM Advertising security type 18
Sep 19 19:40:44 ubuntu vino-server[2419]: 19/09/2022 07:40:44 PM Client 10.242.0.75 gone
Sep 19 19:40:44 ubuntu vino-server[2419]: 19/09/2022 07:40:44 PM Statistics:
Sep 19 19:40:44 ubuntu vino-server[2419]: 19/09/2022 07:40:44 PM   framebuffer updates 0, rectangles 0, bytes 0

xorg.conf (995 Bytes)
Xorg.0.log (13.4 KB)

Thanks

Hi,
Please check if this helps:
Jetson Orin No monitor, VNC only splash screen until monitor connected - #5 by carolyuu

Hi z3n667,

Please follow below steps to enable VNC:

  1. Connect display
  2. Setting Up VNC | NVIDIA Developer
  3. Settings → Sharing → Screen Sharing → set ‘Active’
  4. Run VNC and connect