How to disable DLA support for tlt models

• Hardware Platform (Jetson / GPU):jetson
• DeepStream Version:5.0
• JetPack Version (valid for Jetson only):4.4
• TensorRT Version:7.1

Hi all,
I run deepstream-app -c deepstream_app_source1_peoplenet.txt, and show me :

_context_impl.cpp:1715> [UID = 1]: Trying to create engine from model files
INFO: [TRT]: --------------- Layers running on DLA:
INFO: [TRT]: --------------- Layers running on GPU:
INFO: [TRT]: conv1/convolution + activation_1/Relu6, block_1a_conv_1/convolution + activation_2/Relu6, block_1a_conv_2/convolution, block_1a_conv_shortcut/convolution + add_1/add + activation_3/Relu6

This indicates that the optimized model goes to run both DLA and GPU, but I want to disable DLA to fully run on GPU. and in the config file, in the [property] section, I set : enable-dla=0,
But this shows me above logs, why? This used DLA.


It is the log format.

You can see there is no layer listed below the DLA section.
All the layers are under the GPU part, indicating your model is only running on GPU.


1 Like