How to fix broken CUDA installation [ZorinOS/Ubuntu]?

I have some problems installing CUDA on ZorinOS (I know it’s not officially supported, but it acts much like Ubuntu). I tried to install it the way it is described in the official documentation, did sudo apt -y install cuda and that worked.

However after the installation, the command nvcc was not found (This may have been because I did not do any post-installation steps like adding to PATH, but I’m not sure). The terminal told me I could install it with sudo apt-get -y install nvidia-cuda-toolkit, so I did just that. It did not complete the installation because it said:

E: Sub-process /usr/bin/dpkg returned an error code (0)

So I removed the package (sudo apt-get remove nvidia-cuda-toolkit) and tried again, this time with the -f flag. This didn’t work out either, because:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I manually deleted nvidia-cuda-dev_9.1.85-3ubuntu1_amd64.deb and tried to fix the broken installs with sudo apt-get --fix-broken install. It tries to install the package nvidia-cuda-toolkit, but it always gets stuck on 28% and does not progress any further, no matter how long I wait.

Get:1 bionic/multiverse amd64 nvidia-cuda-dev amd64 9.1.85-3ubuntu1 [263 MB]
28% [1 nvidia-cuda-dev 92,3 MB/263 MB 35%]

My internet connection is alright I tried it several times, it always gets stuck right here. So obviously, I messed things up, but is there any chance to fix it and how (without reinstalling the whole OS)? Can I still get CUDA to work on ZorinOS and are there specific pre- or post-installation steps I may have missed?