How to install steamlink Arm32 bit and Kodi?

i bought this news device
but how to install Steamlink ? it’s a 32bit package.

and kodi

kodi : Dépend: kodi-x11 (< 2:18.1+git20190217.1232-final-0bionic.1~) mais il n’est pas installable
Dépend: libshairplay0 mais il n’est pas installable

VLC crash on my system.

and movie are slow and laggs .

(I use official 2.5Amp 5v RPI PSU)

Not really happy a this moment with my Jetson Nano.

sudo apt-get install kodi,version 17.3

FYI, the nano is 64-bit (arm64/aarch64/ARMv8-a), and not armhf/arm32. The CPU offers a compatibility mode, but the supporting system for the 32-bit foreign architecture is not installed (and would be a very poor performance along with a lot of effort to do so).

so there are few software on it :(

ANdroid should work ? no ?

Do you mean Android on a Nano? Or steamlink on Android? There is no current way that I know of to install Android on a Nano, and I have no knowledge of whether steamlink works on Android.

I exepcted that should be the same of all ARM board like Odroid, but I should ask before buy mine ^^.

Android does use a Linux kernel, but the rest of the surrounding system isn’t the GNU stuff you think of when someone mentions “Linux”. Thus user applications have to be ported when going between Android and regular Linux even if the kernel matches. Drivers and kernel items might have some overlap, but the overall config of the kernel in Android is likely quite different than other non-Android Linux devices. Either way, there is 32-bit Android and 64-bit Android, and you’d have that same conversion issue between 32-bit and 64-bit even on Android.

Overall about the only hope (since foreign architecture would be so incredibly low performance in combination with difficult to add) you have is if someone provides either the Linux source such that you can recompile, or else provides the 64-bit ARM drivers for this specific kernel (or 64-bit user space application if no drivers are involved, and then the kernel version won’t matter).

ok but
NVIDIA Shield Run Android.

There would probably be a variant of the TX1 running Shield, but I doubt the board support package (the BSP providing support for reaching bootable condition which is custom to the carrier board) has ever been ported to the Jetson carrier boards. Definitely Android was never supported on Jetsons (the BSP for external component/layout support is mandatory…a Jetson has a different BSP/layout).

Compare it to a CPU being interchangeable with the same socket on different desktop PC motherboards…you still couldn’t use the BIOS/UEFI from one manufacture in the motherboard of a different manufacturer (and in fact the prepacking of a BIOS/UEFI in a desktop PC motherboard is the reason it is so much more painless…embedded systems don’t have a BIOS/UEFI). Even so there are times when new hardware (e.g., higher density DIMMs) only works if you flash the BIOS on the desktop PC motherboard…you could phrase this as saying the BIOS flash updates the BSP.

Erm, what? The Jetson tx1 is pretty close to the shield android tv at its core. We (developers for the Lineage Android OS Project) have had android booting on the tx1 for a couple years now. The boot stack isn’t always the most friendly, but stuff based from nv-tegra rel-29 (which currently shipping official lineage builds for foster is based on) still works fine on the tx1. My nano is still on backorder from sparkfun, but once I get it, I’ll be working on getting Lineage booting on it too. And technically, nvidia internally supports android on the Jetsons as well, though they don’t release it all in the public source release (I seriously wish they would…), but it’s not impossible to put together the missing pieces like we have.

As a side note, there are internal android bsps for the t186 (the tx2 and tx2i) and t194 (Xavier) as well. I’ve been trying / begging to get those released in any form for some time now, but it’s fallen on deaf ears.

Okay, rant done, I’ll stop assisting the dereailing of this thread now.

Thanks a lot Steel01 !.

Same problem here. I tried to install Kodi on my nano but no way:

Los siguientes paquetes tienen dependencias incumplidas:
kodi : Depende: kodi-x11 (< 2:18.2+git20190422.1151-final-0bionic.1~) pero no es instalable
Depende: libshairplay0 pero no es instalable

I’ve managed to install it on a docker, but I’m not able to see anything after summoning it:

Any hint?

The Nano is 64-bit, the steam app is 32-bit. Although the CPU itself has a 32-bit compatibility mode none of the support for 32-bit exists unless you add it yourself…and that will get complicated. Once 32-bit is in you will find horrible performance. If any of this was built for Android and not regular Linux, then you will probably even more issues. If you just need Kodi to run this, then you can install the 64-bit Kodi without any need to port 32-bit. See:

apt search kodi

To emphasize, Android is not Ubuntu, and even when kernels are the same the surrounding user space support can be quite different. There is no official (NVIDIA) Android support for Jetsons, so you are on your own if you want to port. 32-bit ARM is also not 64-bit ARM.

Hi all,

I finally managed to install Kodi on jetson nano this way:

sudo add-apt-repository universe
sudo apt-get install ppa-purge
sudo ppa-purge ppa:team-xbmc/ppa
sudo add-apt-repository -r ppa:team-xbmc/ppa
sudo apt-get install kodi

The thing is that jetson-nano boots up with Kodi as default desktop, so if you need unity you’ll have to reconfigure. I detected that Unity uses a lot of memory, so I’ve installed Xubuntu. I will test it later. I will post here the results.


sudo apt install xfce4

It should update boot up as default desktop. By now I have:

  • Configured remote access by ssh - OK
  • Mount hard disk on boot - OK
  • Exported NFS directory - OK
  • Installed Kodi - OK
  • Installed Xubuntu - Pending to test
  • Installed docker - Deployed Plex - OK
  • Configured default sound output via HDMI - OK
  • Configured fan by script to work under certain conditions - OK

Thanks for sharing.

By the way, I finally installed lubuntu and jetson nano has not rebooted anymore. It must have to do with the fact that lubuntu’s memory consumption is lower. Keep that in mind. Maybe it’s not necessary to buy a new power supply of 5V/4A. Mine is 5V/3A and with hard disk connected does not reboot anymore using Lubuntu.

Try to play a video using hardware decode ;)

Now you need a barrel jack adapter.

Do you mean to see a video on Kodi, for example? I’ve seen the whole second season of Twin Peaks on my Kodi (shared by NFS with a USB hard disk) and no reboots at all. But Jetson Nano used to reboot before sometimes. It stopped doing it after I installed Lubuntu. And only with Lubuntu (with Mate, Xubuntu, Unity…) same issue.

Have you tried a video in chromium? That and some WebGL demos were what would do it for me. Mostly everything else was stable. I don’t know if Kodi is using hardware decode on nano (at least the apt version). I think libavcodec is used which has no hardware acceleration on Nano for now and the nano’s CPU is fast enough to do most video in software. What’s CPU usage like during playback?

Sure. I see Youtube videos everyday and I also like playing guitar and I love chordify: it’s a web site where youtube videos are shown with the chords to play on a guitar. No reboots of Jetson nano since I “lighted” the operative system.

If you need me to check version, packages or anything to make work the Jetson Nano with a 5V/3V (non barrel) adapter just let me know ;)