Kodi (XBMC) with full HW acceleration (stable: 14.0, testing: 15.1)

[2014-09-17] Now with full acceleration and from a PPA for more convenient installation.

Installation instructions in the wiki:

http://elinux.org/Jetson/Installing_Kodi

Do also read the notes about getting jitter free playback and how to remove the old XBMC if you had one installed.

Thank you very much!
Does it support other arm devices? Such as chromebook with arm CPU.

That build is for X11/GLES/EGL. It might run on other ARMv7 devices supporting those. I’ll package a new version with OMX HW decoding soon and while it is a standard API as well, I don’t think it runs on other devices without tuning.

Tuomas,

Is XBMC required?

on ubuntu I would like to use OMX HW decoding to move USB v4l2 camera sensor output to CUDA, for processing and possible display….
and publish reduced test case as open source on github**

many thanks

Jonathan

**building from Raspberry Pi with openGLES:
https://github.com/peepo/openGL-RPi-tutorial

Thanks for this build it works fine on my Jetson

Ok. That works. That last line is a must. Now how do I go about getting makemkv for arm? Last time I tried it took hours to compile on jetson and didn’t work. Thanks.

No.

Please start a new thread for this. I’m not familiar with CUDA so I don’t know how the interact with it. But a few comments still. What is there to decode if you get the video from the USB camera? It’s already raw YUV. At most you might want to do YUV to RGB conversion. That is quite heavy so if your CUDA application could work directly on YUV, it would be much more efficient. If you want to have raw RGB in your CUDA application and want something else to do the conversion, you might want to use GStreamer in your application. With that it’s quite easy to read from V4L2 camera and do the color space conversion with nvvidconf.

Tuomas,

apologies for confusion, as per your response on other thread "bcm_* functions are Broadcom specific "

my request in this thread is for usable OMX HW on Jetson Ubuntu.

the guff about CUDA was only to widen application or usage from openGLES…

bear in mind search engines require this type of detail to find…

Ciao Kulve, thanks for your build.
I just started testing (the only way I can contribute) and I think I found a bug:
in the weather forecast section, when you try to set location or even location name the USB keyboard doesn’t work anymore and the on screen keyboard has buttons with non character and nothing happens in the “textbox” if you push them. Is the only section where typing is needed, I’ll try also the others.
Is that a issue related to the elimination of all the easy access applications such as ORCA, etc.?
I always did the same with Frodo without having any problem.
By the way, my impression is that your build is a bit smoother than Frodo available in repo.
Very good job :)

installed xbmc today with no issues. I did not run into setting location problem (using weather underground service). Thanks for making this build for jetson tk1!

Does anybody know if there is any way to monitor the GPU load?

See this post:

https://devtalk.nvidia.com/default/topic/761175/embedded-systems/jetson-tk1-graph-gpu-usage/post/4292513/#4292513

I did see good correlation with that while somebody else mentioned that it doesn’t show anything…

I’ve pushed a new version of the Kodi (XBMC) to PPA and I would like to get feedback if it’s working for people before I’ll rewrite the first post to point to that.

The new version is fully accelerated!

Do note the instructions about removing the old version and its configurations if you have it already installed.

http://tuomas.kulve.fi/tmp/xbmc-jetson/README.ppa

720p and below plays fine with hw but 1080p (and probably higher res) is just black screen with sound.

[/url]

[/img]

Thanks kulve. Installs fine (Running Grinch 19.3.6). Playback of Sintel 1080p seems to work along with some 576p material though to be honest I can’t really tell if it is HW accelerated apart from in the menus.

Any chance you will push your extra packages over that you have on your site specifically the pvr mythtv one or no need for any changes in there?

Thanks again

MP4 videos play fine, even 2160p 30 fps

Great work!!!

I though I already did? Version 1.9.20-14trusty should be found from the PPA.

I’m happy to add more packages there, so just let me know what’s missing.

I’ll rewrite the first post to match the PPA instructions.

Just tried Big buck bunny 216op 60 fps. Only black screen and sound

Kulve, you are right. It was there. Works fine with mythbackend (Also hosted on Tk1 with Sony PlayTV tuner) Tested both SD and HD streams.

I’m not surprised, that’s a lot! I don’t think 2160p60 is supported by the video decoder. And HDMI 1.4 is limited to 2160p30 anyway.

“On the video side, Tegra K1 continues to support 2160p30 (4K or UHD video at 30FPS) encode and decode.” From Anandtech http://www.anandtech.com/show/7622/nvidia-tegra-k1/4

But HDMI 1.4 supports 1080p60 right?