How to launch Nsight system GUI from Orin AGX

Hi!

I am looking to use a GPU profiler for development and as far as I understand, nvidia nsight system is already installed with Jetpack’s components. The nsys command line offers an interface with the CLI version of it. But I would like to use the GUI version. Please let me know if it’s possible, and if so how do you launch the application.

Thank you and have a great day!

Hi,

The native profiler on the Jetson is the CLI version.
If you want to use a GUI one, please launch it on a desktop machine and remotely profile.

After you install all the components for the host from JetPack, you can launch it as below:

$ cd /opt/nvidia/nsight-systems/2021.5.4/bin/
$ ./nsys-ui

Thanks.

Thanks for your quick answer!

I already tried to install the profiler on a desktop (Ubuntu 18.04 and/or Windows 10) but it said there was missing a file for tegra release (which i guess it’s the driver for the Jetpack version of nsys). Do you mean I should install Jetpack on my desktop? Or only the profiler from Jetpack? If so I didn’t know it was possible!

Thank you and have a great week!

PS. I have joined an image of nsys-ui on my Ubuntu 18.04 desktop

Update: I have found the package management server for Jetpack components!
But now i get this error (the same as windows)

This is a screenshot from my target jetson

Hi,

Yes, please install the host components from the JetPack.
It has the cross-compiling toolkit which is required for remote profiling.

Thanks.

Hi,

If you look at my update from the last reply, I was able to install the Ubuntu18.04 component of nsight from jetpack 5 package server. Yet I still get the “Target not supported” error. I have joined in my previous post a screenshot of the directory of nsight-systems.

Thank you!

Thanks for the clarification.
We are going to check this and will update more information with you later.

Hi,

Please use the Nsight System v2021.5.4 for the Orin profiling.

When installing the components from JetPack, there are 2021.5.2 and 2021.5.4 installed into the /opt/nvidia/nsight-systems folder.
We can access Orin successfully with the 2021.5.4 tool and do reproduce the target not supported error with the 2021.5.2.
It looks like the support is added into 2021.5.4. Would you mind giving it a try?

Thanks.

Yes, you were exactly right!

However, the 2021.5.4 revision was not installed, so I add to install it with

sudo apt-get install nsight-systems-2021.5.4

But now it works just fine!

…I guess the Jetpack component was not necessary at the end of the day.

Well we can close this issue now! Have a great day!

Good to know it works now.
Thanks for the update.